Screwed CD structure - any help?

vbimport

#1

Hi there,

I just grabbed a CD I burned a month ago to copy some data off this one - and was really surprised to learn that the whole disc is totally screwed. While all the directories and the filenames are show up just fine, the content of the files is garbled - ie., html-files do not contain text, but binary stuff.
It seems like there is some sort of offset: the files do not start where they are supposed to start and contain stuff from other files - the qhole file structure is f…ed.
I burned the CD with nero, according to its info it’s a mode2-data cd and has an iso9660-/joliet file system.
Needless to say, the data on the disc are important, and I don’t have a backup - it would be really great if you could help me here.

Thank you in advance,
Thoralf.


#2

try recovering the data with ISO Buster.


#3

thank you for your answer,

… tried both osi- and joliet mode and all available extraction methods - to no avail. Damn. The data is on the CD, I just can’t access it :-((

any more ideas?

thank you, thoralf.


#4

ISO Buster is about the best of the freeware recovery tools for CD/DVD’s. the only other option I could reommend is stellar Phoenix CD Rom. it is more powerful than ISO Buster but it’s not free. It does however have a demo version you can download and try.

http://www.stellarinfo.com/cd-data-recovery.htm


#5

hi iss,

thank you again. I tried the app mentioned above - it keeps crashing when it reads the contents of the CD, so it’s useless :frowning:
I ended up copy & pasting the really imported stuff manually from an image of the disc, which was a pita. Couldn’t extract anything, though: ever tried to find the beginning of one JPEG/GIF/PDF in about a thousand files on an image of about 700 megs?
Another thing that botheres me: I don’t trust nero anymore, since I used this software to create this coaster. with standard settings, afair. So what will happen next time?


#6

Did the CD read ok after you burned it?
If it worked ok then it is likely to be you are using poor quality CD-R media that degrades quickly over time.
If it didnt work then it is probably the fault of Nero or your burner, if so you will need to try burning at a slower speed, or it is possible you are using very poor media that is never readable.

As for your lost data I think if the 2 programs mentioned dont work, and the files still appear readable (can be copied to the hard drive) then there is nothing that can be done.

Ben :slight_smile:


#7

whateve app you use to burn with I would suggest checking the disk after the burn if it contains important data. Nero has a built in quality check or you can use a freeware app like CDCheck. After losing data to CDRW disks that went bad I gave up packet writing software. I now use external Hard Drives for data back up in combo with regular back ups on Quality DVD+R media.


#8

hi there,

the disc can be read fine, and all the files show up - only with wrong contents. so no faulty media, i suppose.
as far as i can tell, the logical disc structure is screwed, and i blame nero for this - i didn’t use any special or weird settings, just a straight “new cd”-project. i didn’t let nero check the written data, which is definitely my fault - i was in a hurry and needed some gigs quickly, but then again, this is no excuse …
with a little knowledge of the structure of iso images and cd formats, it shouldn’t be too hard to write a little utility that corrects the screwed pointers to the files. but that’s far beyond my programming skills …

thank you,
thoralf.


#9

Goodlight, if this post is still active then what ever one tries, see if one can turn off or ignore joliet file system in the options IF YOUR RECOVERY PROGERAM HAS THAT OPTION in the ISO section.
i downloaded 2 $ware programs [$ware = payware] and both in their trail versions finally could read the bad CD when the joliet was turned off, and i CANNOT VERIFY that the files are savable till i buy the program[s] but it seems of the two, CDroller is better, as the OTHER program added adware and i do not mention any program free or $ware that adds adware.
Now it might be that one of the other programs i have yet not tried may solve my CD error problem if it does i will post that program’s name here.
In CDroller i first tried their default settings and what could be recovered was what my cd program could already read which was ~8 files out of hundreds , but then i followed CDroller very well placed interactive help text which explained to try other settings so in its interface under VIEW> PREFERENCES> ISO READER i ticked/checked the "ignore Joliet file system [use only ISO 9660] box and retried its several recovery styles and after i randomly selected “identify RAW ISO data” which took a long time[50mins] to read ALL of my hundreds of files and folders that read as empty [but i knew had over 4GB yes GB OF INFO] FINALLY “SHOWED UP” and reads can be recovered 100% once the program is registered, BUT AGAIN being this is still via the TRAIL VERSION i cannot say it worked as to recover the files but found it of interest how the joliet function set as mention caused files that where completely gone to reappear so i felt why not post it as it might help others in their problem,peace