SATA<->PATA adapter ok for PX760SA?

Hi,
I’m having troubles trying to use a PX760SA driven by a SiliconImage 3112 SATA controller, as I reported in http://club.cdfreaks.com/showthread.php?t=187907.
Plextor support told me to try the burner on another PC, but I cannot do this (I expected plextor support to be better).
Instead of buying a new SATA controller, I’m thinking about buying a SATA<->PATA adapter, to attach the burner to a free ATA connector I have.
Before I spend more money, do you know whether this could work?

Thanks.
Spaceman

I have a generic adapter with a SiI 3112 and have no problems with my 760SA. If possible can you test the adapter and drive in another system? What are your system specs?

My current system is a P4PE motherboard + P4 + Windows2000/Windows XP/Linux (no matter changing op. system, burning is ok, but verify fails).
I tested the controller+burner in another PC (asus P5A-B + k6-2 + Windows XP) but the results were the same :-(.
Have you ever verified your dvds? Nero tells me writing went ok, but it’s not true!!
I ran the PX760 self test, and it went ok, so I’m pretty sure there is some incompatibility issue.

Spaceman

The old 712sa and 716sa models were simply 712a and 716a’s with SATA adapters on them, simply removing the adapater turned the drive into the PATA version.

I’m not sure if this is the case with the newer 760sa but if it is, then it would be silly and probably problematic if the drive was being converted into SATA and the back to PATA.

Can someone confirm if this is true with the 760sa?

No. Only the 712SA was a plain 712a (IDE/ATA version) with an extended (longer) case that contained an additonal IDE to SATA adapter. The mainboard of the 716SA features a true SATA solution, as do the mainboards for the 755SA/760SA.

In the case of the 760SA you can find pictures of the relevant part of the mainboard here: http://homepage2.nifty.com/yss/px760sa/px760sa_top.htm . You can find pictures of the 712SA-Adapter here http://www.aceshardware.com/forums/read_post.jsp?id=115124193&forumid=1 or here http://www.skenegroup.net/fi/artikkelit/plextor_px712sa.2 .

Thanks for the correction, now we know :slight_smile:

I certainly hope these SATA problems get worked out before they discontinue the IDE connections on motherboards. I just upgraded my MB partly to make sure I could still connect my drives. Optical SATA has a way to go.

You’re basing everything on Nero verify? From what I’ve read, it isn’t very reliable. Everything is working otherwise?

No, I’m not basing only on Nero. I verified the written files with linux diff and it told me that many files (but not all) were different from the source

So, if Plextor itself used a SATA<->PATA converter, it should be possible to drive a SATA burner using an “external” converter.
But I read that conventional converters work only for SATA hds and not for optical units. So, what should I look for??

I thought that maybe you have a firmware revision different from mine.
I’d really appreciate if you could send me your firmware or at least tell me what revision the sil3112 shows when booting
To download the firmware from your card you can use the updflash.exe utility, available at http://www.siliconimage.com/support/supportsearchresults.aspx?pid=63&cid=15&ctid=2&osid=0&

You are my only hope, currently.
Thanks

Spaceman

Does the SiL 3112 even claim support for ATAPA devices? If you look at the compatibility charts on the Plextor web site, the majority of Sil 3112-based unts report NG, although some, notably the Adaptec 1205A report success.

Sil3112 should support ATAPI devices, depending on what BIOS it’s running. As you noted, the 1205A works fine.

Is there a way to switch the RAID BIOS of on-board sil3112 (Asus A7N8X-E)
for the non-RAID one (presumably more compatible with Optical drives).
I suspect this is what makes the difference between working and non-working MB!

TIA

I’m using a SATALink card from SiI, BIOS 4.2.1

I had a 4.1.x on my board, and tried the ones from http://www.siliconimage.com/support/supportsearchresults.aspx?pid=63&cid=15&ctid=2&osid=0&
but they give boot (post) problems.

I cannot find the bios release you have on the net… do you have it as binary file, or could you kindly “download” it from your card?

Having just bought a 760SA today i had problems with it initially.

i have a kn8-e deluxe mobo which is nforce 3 sil 3114

my problem was when burning i would always get verification errors

the 760SA was originally plugged into the sil 3114 sata controller ports

when swapped over to the nforce sata contoller ports the verification errors stopped

they were genuine write errors btw as i checked the cd against the image with beyond compare

i hope this helps someone out as there isnt much information out there on the 760SA

ps the plextor site states both controllers on this mobo should work. wonder if they actually tried it

Verification errors can also be a software thing. I know of one confirmed recent issue with Nero in conjunction with PX-760 drives. 7.7.5.1 fixes this AFAIK.

i use imgburn :). i only use nero for making iso files.

also it is the SIL3114 chipset, but i cant edit that post for some reason

There is a 30min time limit for editing. I fixed the numbers.