SATA optical drives and Nvidia and AMD Soutbride/Northbridge chipsets - problems

vbimport

#1

I had spent about 3 days searching for information on why my LG GGC-H20L Bluray/HD DVD reader drive would not work on my Asus M2A-VM HDMI mobo (AMD 690G chipset). LG first said the drive was bad, so I returned it. The second one had the same issue, so I knew it was no longer the drive.

What would happen was as soon as I plugged in a movie, the disk would spin and the read light would blink once, and then six quick successive blinks followed by silence, and then infinately repeating the same thing. Movies, Bluray, HD, and regular DVDs could not be watched. It was as if the drive was being accessed by multiple sources all at once. Movies would hang or skip showing 1 frame every 60 seconds. I tried cables, I updated the Bios, updated the chipset drivers - everything I could possibly think of but had no luck. So I started searching and came across a LONG thread on CD Freaks about SATA optical drive problems. In reading through some 15-20 pages of that post, someone said that AMD and Nvidia chipsets don’t work well with SATA optical drives. WHAT? I thought - how can that be, that just doesn’t seem right. I continued to read past that post and saw mention of a Plextor DVD reader/burner that came out several years ago (model # included in the post) and it was noted as one of the first SATA optical drives on the market. Hmm, that made me think. I had that same Plextor drive and I pulled it from my Nvidia Nforce system because it never worked right. Movies wouldn’t play, DVDs wouldn’t write, data could not be read - even CDs failed. All I can say, is for doubting the soundness of that statement about incompatability with Nvidia and AMD chipset, I apologize - but only after verifying my findings.

So, I took the LG drive to another machine I have - An Intel based ASUS P4C-800E deluxe. Supports only SATA 150, and I would not use it to view the HD content, just rip it to view on an HTPC later. Guess what - WORKED FLAWLESSLY. That Intel chipset happens to be an Intel 875 chipset - like I said, don’t look to use this to watch HD content (lacks support for Core 2 Duo or AMD x2 processors recommended and required for HD 1080 content viewing).

So why this post? Well, because of all the time it took me, I could not believe that I would be the only one. And I wanted to come to the point for the next person that has problems - this may save them time, as the post I discovered took a bit to read, it saved my sanity because I am no noob when it comes to computers, but up until that revelation, it had never occured to me that the chipset could be the problem.

I informed LG of my findings. The guy had never heard of such a thing there in phone support, but confirmed that he had received similar calls about similar incidents but could not verify what their chipsets were. He asked where I found this information, and I pointed him here.

I was recently looking at buying an Nvidia 790i/790i Ultra chipset mobo until this problem came up. I have now shifted focus back to an Intel Chip set and ATI graphics solution.

Curious though - I was reading the forums here, still, and it suggested a SATA add on card. I picked up an SIIG card (SATA II PCIe Raid - 2 port) card and installed it in the ASUS M2A-VM mobo (PCIe slot) and fired everything up. Seemed fine, except for the fact that apparently, that PCIe port shares IRQs with my sound card, and sound was lost. Fine, I’ll work on that later. Loaded up Bluray movie - absolutely no issues, played perfectly. I rebooted the computer, and then the blinking light - no playing movie content problem returned and remained. I do remember the same exact situation when I plugged the drive into the SATA port with the 690G chipset. It worked, I rebooted, then it worked no more. Although I am still quite convinced it’s a chipset compatability issue, anyone have any idea why it works until I reboot? Also, even though the drive seems to behave as though it is being worked over, and media won’t play to the screen, it does allow me to RIP the movies in light of the business of the drive. For those familiar, I have ran the Cyberlink BD Advisor and have all greens. I have a 5400+ AM2 X2 processor, 2GB PC-6400 (800mhz) ram, ATI 2600XT HD 512MB graphics card, and a SATA II HDD. I know that spec’d, as far as requirements, are not the problem. I am not over clocking either, and heat is sufficiently managed. I have a 610w PSU, and for my hardware, via the Antec PSU calculator, I’d only need about 288w of power. So I know it’s not a power issue (unless the SATA rail is bad which I did not seek to test since the drive did not appear to be losing power - but certainly, something I could try to test). Any one have any thoughts.

The Drive is however, very nice, quite, and the blue lights match the lights on my HTPC case. LG (formerly Goldstar) has made drives for years for OEM companies like Compaq, HP, Dell, etc but they show up as HL-DT … drives. I believe that is what I was told and remember from my earlier days. In any case, I don’t believe it’s the drive, but the compatability. Be aware if you are buying any SATA optical drives.

I could also try some different SATA controllers to see. I believe that Promise was shunned in that same forum, so perhaps I will avoid that one.

Thanks for all the expert posts everyone has put here - it really was interesting reading, and helped to provide answers to a frustrating problem.


#2

Hi,[quote=dbdbdb;2138978]I had spent about 3 days searching for information on why my LG GGC-H20L Bluray/HD DVD reader drive would not work on my Asus M2A-VM HDMI mobo (AMD 690G chipset).[/quote]How is the Sata controller configured?
I wouldn’t expect any problems if it is set to IDE mode. My brother has the same motherboard (without the HDMI extension) and runs two Sata DVD burners without problems.

Michael


#3

Mine is also configured as IDE on both the AMD and Intel chipset based systems. Latest firmware and drivers installed.


#4

UPDATED:

After working with a guru at a local retailer, he came up with a suggestion I had initially shot down as the cause. As I mentioned, I configured my SATA drives in the IDE compatable mode when I built the systems (in XP and Vista). It was done out of PURE laziness on my part and for no other reason but that.

The guru at the computer shop suggested I try a test build, but instead, switch the SB SATA controller to AHCI instead of IDE compatability mode. RAID was not recommended since, in this case, I am not running anything on those machines in RAID. The expert stated that AHCI mode maintains greater compatability for SATA devices then the IDE Compatability mode. The test build is necessary since, as he more or less stated, can’t port the HDD OS install from IDE Compatability to AHCI without have OS crashes or failure to boot. Makes sense - I’ve witnessed this on non-raid to raid conversions.

Well, I am always looking for a shortcut. After going to WIKI to find out just WTH AHCI stands for, there was a link to a Microsoft forum for how to enable AHCI on a system where AHCI was not the method selected when building the OS. It entailed changing just 1 single value in the registry, rebooting, then enabling AHCI in the BIOS. BUZZZZZZ! I’d recommend that you don’t do this. It killed my Vista build. I’ve got two identical systems, so this was not a big deal - I could Ghost it over and be happy. BUT, if the test build did work, it would mean that BOTH systems would need to be rebuilt anyways under AHCI instead of IDE Compatability mode.

The test was successful. AHCI mode worked. Meaning, I was wrong about the SATA drives and AMD/Nvidia chipset compatability issues, although I do stand by that in my opinion, they don’t work well with. I say this because my Intel chipset based system had zero issues with the SATA drive.

Some items to be aware of. This may or may not apply to you, but I discovered this in my test build. I am using a ATI HD2600XT 512MB graphics card. I installed the latest Catalyst Drivers (8.10) and PowerDVD 7 (7 is the version that will play HD-DVD and Bluray / 8.x will only play Bluray). I updated to the latest/final build for 7.3 ultra. When I played a normal DVD movie, no problem. When I played Bluray or HD-DVD, I had problems. A search of the Cyberlink support page FAQ suggested either the drivers for the graphics are bad OR PowerDVD didn’t install correctly. Well, it just couldn’t be the Catalyst Drivers now, could it? So, I uninstalled the PowerDVD 7 and reloaded it. This time, with NO updates to the latest version. Problem was still there. Well shucks. Since this is a test build, I am not concerned about what I do it. So, I uninstalled the 8.10 drivers from ATI and slapped on the 7.10. That’s quite a step back, I know, but these two machines in particular are about a year old, and the 7.10 is the Catalyst version that I did install with no probs. Guess what - worked perfectly. Still having a play issue with Ironman, so I am going to try to update the PowerDVD software now to see the outcome. But, HD-DVDs play flawlessly. Some Bluray titles play fine as well. Only one I had problems with was Ironman. RIPing Blu, HD, and plain DVDs works fine.

so, in summary, AMD and NVIDIA chipsets appear to need to be set to AHCI when a) building your OS (requires a driver disk during install or you’ll get BSOD during install of XP/Vista); AND/OR b) using a SATA Plextor (early model) drive, or the LG drive I mentioned in an earlier post.

I apologize if this information is common sense to some people, but it’s meant for those who are less skilled than others.

Have a nice Halloween (or dia de los muertos)

DB