Sata controller on main board?


#1

On a MSI Z77A-G41motherboard with Pentium G2020 cpu at 2.9GHz that has 2 sata hard drives and 2 sata optical drives connected, all drives are recognized in bios, but only hard drive 1 is recognized while hard drive 0 is not recognized when boot to Win10 install disk. Also CD/DVD disks fail to boot about 9 out of 10 times. Does this mean the main board sata controller has failed, or might a bios upgrade fix the problem? BTW I tried replacing sata cables and tried different sata ports, and neither helped. Memtest86 was run and found no errors. I did notice clock in bios was 4 hours slow which may indicate cmos battery needs to be replaced. Could a weak cmos battery cause such bizarre behavior with the sata drive connections?


#2

could you possible have a bad optical drive? or a bad burn?


#3

There are 2 optical drives, and both have the same problem. It’s unlikely both drives would go bad simultaneously.

Edit: Late today the PC booted normally once to bios, but on a second startup lights and fans came on for about 10 seconds, shutoff a few seconds, back on for 10 seconds and shutoff a few seconds; this sequence repeated over and over until power was turned off. This seems to indicate either a a bad power supply or bad motherboard. Is there a way to determine which it is?


Windows 10 activation?
#4

Not easy without an alternative hardware. A power supply is the easier was to try, but the mainboard/CPU is more suspect for these errors

My MSI Z77-G45 had also strange problems and <2 years the board was defect and the CPU also (which happens very rare)


#5

Which motherboard did you get to replace the MSI Z77-G45? I’ve done some looking in case mine needs replacing to find LGA 1155 boards hard to find and pricey when found, and most other boards I find have too few expansion slots. I’d like to have a Intel board with 2 pci slots and 2 pcie slots. Do you know of any in case I do need to replace my motherboard?


#6

My MSI worked only for less than 2 years, so there was no problem to get another S1155-Mainboard in 2014. I get this board:

https://www.asus.com/de/Motherboards/P8Z77V/

Today it will be hard to find an S1155-Mainboard.


#7

Motherboard was replaced with Gigabyte GA-B250M-D3H with Pentium G4400 cpu install and 4GB DDR4 PC2133 RAM. On startup there’s a single short beep, and on the monitor appears a screen that shows “Press Del to enter bios setup,” “Press F12 for boot menu” and a couple of other options. However, there’s no response from any key input from keyboard; I’ve tried PS2 and USB keyboards with same results. Late Friday I called Gigabyte support and was told to try USB keyboard after initial try with PS2 keyboard failed, and they were closed before I could call back. I can’t call back to Gigabyte support until Monday because they’re only open Monday through Friday. Has anybody had this issue with a new motherboard, or does anyone know a possible fix for the problem?


#8

Did you try a native PS/2-keyboard or an USB with PS/2-adapter? I have bad experience with adapters and keyboards


#9

Native PS2 and USB keyboards were tried.


#10

So the board have a hardware-defect, I guess

A PS/2-keyboard should always work.

A USB-Keyboard should work at POST and in Bios, no matter which settings are activated in BIOS.

I know problems with actual Asus-Boards and Windows 10 with some settings, but that´s another story


#11

Around 20 years ago I had a new motherboard fail to post, and the store who sold me the motherboard told me to disconnect all hardware except graphics card and monitor and reconnect hardware 1 at a time restarting after each device was reconnected if it posts with only the video connected, but the PC still failed to post. The store said the motherboard was bad and replaced it. A couple of years later the same problem arose with another PC, and the same steps were followed resulting this time in PC booting after all hardware was reconnected. I’m unsure why this works, but it does.

This afternoon I followed that same procedure, and the new motherboard booted until the last optical drive was connected whereupon it froze at the same point in my initial post above. A second sara cable was tried with no help; then I tried switching sata ports with the problem persisting. I also tried switching sata cables between the 2 optical drives, and the problem continued. Finally I determined the system would boot correctly only when that last connected optical drive is disconnected. Apparently a bad optical drive was the cause of the problem. I’ve never had a bad drive cause this kind of problem. All other drive failures I’ve seen simply resulted in the bad drive failing to read or write.

Now I wonder if my conclusion may have been faulty about the motherboard replaced being bad, and could that bad optical drive have caused the computer to cycle on and off without booting. Maybe that motherboard isn’t bad after all.

There’s 1 more thing I need to determine. I’ve been dual booting WinXP and Win10, and while using the board that was replaced sata mode in bios had to be set to ide in order to boot WinXP. This new board has no ide setting for sata mode in bios. Does this mean WinXP won’t run on this board, or is there a way to boot WinXP without sata mode set to ide?


#12

Oops, forgot this to mention.

If a board wont boot, I disconnect all devices and reset BIOS

Intel stopped XP-support ages ago, official support AFAIK the 7x-chipsets were the last with official XP-support.

Running XP will be very hard or impossible, because without Legacy-Mode you need AHCI-drivers to get XP work

For some newer chipsets Fernando modified Intel-drivers, maybe you will found here something

https://www.win-raid.com/f23-Specific-Intel-AHCI-RAID-Drivers.html

The other way is to buy a PCIe-card with SATA-controllers which have XP-support, something with Marvell-controller, Sil, Asmedia. But if you run a SSD these controllers will not work with full speed and best compatibility.

If you have a own XP-HDD it should work stable. But XP will be not work very fast because for most components on the board there´s no drivers


#13

Can those modified AHCI drivers be included in BIOS since that’s the only way WinXP might boot? I have a PCI SATA/IDE card I tried to use for optical IDE drives on a SATA only system but was unable to get it to boot to Windows XP install CD… Do you know if use with hard drives might work?

Today I got an error message while trying to boot to a BartPE CD stating the system BIOS was not fully AHCI compliant and that the BIOS needed to be updated. I called Gigabyte support to see if there’s a BIOS update to fix this problem and was told only Windows 7 and later will work with this board. According to »www.comx-computers.co.za ··· 4810.htm that seems to be true. I guess that means I can no longer run WinXP unless the board that I replaced is still good, and I reinstall it. They used to make software that’s backward compatible but not so any more!


#14

Do you found an AHCI-driver for this chipset? I don´t have a B250-Mainboard and so I never tried to install XP on it.


#15

The SATA Mode in BIOS is set ti AHCI, but I don’t think there are drivers in Windows.


#16

Without AHCI-drivers for XP it wont work

How/why do you use still XP? Would a Virtual machine work for you?

Otherwise, the way which should work to run XP on your board is to buy a cheap PCIe-SATA-card which support XP.


#17

I only use WinXP to run a few apps that won’t run on 64 bit systems since my Win10 is 64 bit. I don’t know anything about virtual machine or whether that may work for my purpose. Would WinXP boot if connected to add on card,and would Win10 recognize the drive while booted to Win10?


#18

Do you want both OS on same HDD/SSD? I recommend to use 2 HDDs/SSDs, once for every OS.

Because XP don´t have drivers for those Add-on-cards you have to use an USB-Floppy-drive to give XP the driver for the card while installing.

Or using n-lite

http://www.prime-expert.com/articles/b02/installing-windows-xp-with-f6-ahci-raid-drivers-from-usb-only/

Here also some ways, but don´t tried em

http://www.prime-expert.com/articles/a01/installing-windows-xp-with-f6-ahci-raid-drivers-from-dvd-without-floppy-drive/

Or you try the easy way first and use a Virtual Machine

https://my.vmware.com/de/web/vmware/free#desktop_end_user_computing/vmware_workstation_player/14_0|PLAYER-1411|product_downloads

https://kb.vmware.com/s/article/2013483

The player is free. You only need a XP-CD or iso.


#19

XP is already installed on a hard drive separate from hard drive on which 10 is installed, and I don’t need to reinstall it. Also I’d lose all the XP updates that were done since XP updates are no longer available from Microsoft. Will the existing XP boot if I connect the drive it’s on to the PCI adapter, or is booting an existing install with hard drive connected to the adapter not possible?

The VMware links show 64 bit which makes sense since Win10 is 64 bit, but WinXP is 32 bit. Will that still work? How is virtual machine run once installed? Is there an option in the boot menu to choose it, or does one boot to Win10 and then click an icon to start virtual machine? How do you exit virtual machine when you’re ready to shutdown or switch to Win10?


#20

Are you sure about XP-updates? I can try to test it, otherwise an old version of WSUS software update can download and install these updates.

Your XP-installation will not boot directly from the adapter because it have no drivers for this adapter.

The 32/64Bit-versions of VMWare are only depend on your host OS, if it is W10-x64 you can use the 64Bit-version and make a VM with every 32/64Bit-OS

If you choose the 32Bit VMWare it is possible but makes no sense

If you use a VM you have to start your Host-System which is W10, click on the VMWare-Icon and start the XP in another window.

In the VM you can shutdown XP like you did before :wink:

All the time your W10 run, you can switch everytime between W10 and XP or minimize the VM-window