Samsung/TSST burner doesn't see DVDRW (but sees everything else)

vbimport

#1

As the title says, I have a SH-162L internal burner which has gradually lost the ability to see rewritable DVDs. First it’d occasionally refuse to see a disc, then it got to the point where I had to reload the disc several times before it’d eventually see it and burn data on it. Now, it doesn’t see them at all.
I insert the disc, the light blinks a bit, then it stops doing anything and the software reports “no media present”.

I’ve tried several brands of disc, and I’ve tried connecting it via a USB2.0 cable (with which it’d worked previously) to my Linux notebook; nothing seems to work.

Strangest thing is, it burns everything else with no trouble at all. CDs, CDRWs and DVDs all work flawlessly.

This is extremely annoying, since I have some two dozen rewritable DVDs I can’t use anymore.

Is there any way to make it behave?

Thanks.


#2

I think that the issue is not related to the drive, but to the media itself.

You can try to use a different drive to do a FULL erase of these discs, maybe your samsung will be able to recognize them again.

many times, a full erase done with ImgBurn proved to be a remedy for this situation. Paradoxically, a full erase done with a different software seems useless to recover a disc :confused:


#3

Rewriteable DVD media have different optical properties than other discs. I think, it’s not impossible that the lens has difficulties either due to dust (see if cleaning helps) or the drive is starting to die.

Michael


#4

If the drive is dying I’ll be mightily pissed. I’ve had it for a while, but it hasn’t even burned two hundred discs.

And it seems I spoke too soon; I’ve been trying to get it to burn a DVD+R, of a brand that it’s burned hundreds of times before, and it has trouble recognizing it.

sigh I’ll try cleaning the lens, but I have little hope.