Samsung SW-216B

vbimport

#1

I recently bought a used Samsung SW-216B CDRW from 4seller.com

I'm trying to install it on a Windows 98 machine and having very little luck. This is only the second or third CDROM device I've installed.

In the config.sys, I have

device=c:\cdrom\sscdrom.sys /D:SSCD000 /P:1F0H,14

On boot, it appears to recognize the cd and gives me the SSCD000 ID as being the name of the CD and the logical unit is 0.

When I try to access the drive within Windows, I get "Drive not Ready, Retry, Cancel" messages.

Under the system properties tab it recognizes the drive as a Samsung CD-R/RW sW-216B.

Options are set to Disconnect and Auto Insert notification both on.

Once, I tried setting Sync Data Transfer to on and was able to play an audio CD in the drive.

I rebooted and can no longer play the cd. I've switched this setting on and off a couple of times, rebooting each time, with no luck.

I have also tried setting DMA to on, but that has no effect.

I've deleted the registery entry under HK_LOCAL_MACHINE/enum/SCSI and rebooted to no effect.

As an attempt at getting this to work in DOS mode,

In the autoexec.bat I have

c:\cdrom\mscdex /D:SSCD000

When I reboot in dos mode, I cannot access the E drive (the CDRW device).

Ideas?

Is this a bad drive or am I missing a step or two?


#2

Are the master/slave setting ok? On each IDE channel there can be 1 master and 1 slave (or 1 both should be Cable Select).
Are the cable hooked on correct? I mean the are fully attached not only one side plugged in you know.


#3

Yes, the cable is connected in the same manner as the drive I removed.

I’ve tried jumping it as master, slave and the third setting.

The original drive was cabled to the sound card, but I could not get the drive recognized when I put the new drive on the same connection.

I’m thinking it was due to the device settings according to a document I found late last night on the web.

device=c:\cdrom\sscdrom.sys /d:sscd000 /p:1f0,14,1

is what that document suggested. Where 1f0 is the address, 14 is the IRQ and 1 is slave

The reason I think this was wrong for using the sound card as the controller was the IRQ of the sound card is not 14. And, the sound card would of needed a 0 instead of a 1 due to the drive being master for that controller vs slave.

When I moved the drive onto the same ribbon cable as the hard drive, set the jumper to slave, and used the device setting mentioned above, the drive is recognized on startup. I think this is because the ide controller is on 14. But I’m still unable to access the drive in either DOS or Windows.

I’m learning as I go…

Anything else I should check?

:confused:


#4

You are halfway there, once you can get it to recognize the drive in the bios, make sure the DMA is on, and check your device manager to see if it shows up there.

Double check and make sure you have the ribbon cables and the power cables, and check to see if those jumpers dont actually reauire a second jumper.

BTW is this all scsi?