Samsung SH-S203B Firmware Problem

Dear CD Freaks.

I have a problem with getting Samsung SH-S203B to work proberly on my computer, and I also have a issue with upgrading to the new firmware version. Also shouldn’t it be possible to boot from this drive also?

My harddrive is running on IDE, and Samsung SH-S203B is the only drive that is connected to the Sata Controller.

My motherboard is a : Asus A8V Deluxe Bios V. 1018.002
DVDWriter : Samsung SH-S203B Bios V. SH-S203B_SB00.bin

Also I am confused about that the Oem Code is 0. It’s my second drive that don’t have the proper Oem Code. So it must have something to do with my motherboard. I simply have no clue about it.

Please help me solve this problem…

I am new to this forum, so I hope that my post is in the correct section.

Thanks…

Best Regards,
Michael

Hi :slight_smile:
Welcome onboard Eaglejunior. :iagree: :clap:
I am not sure your motherboard SATA will support SATA DVDRWs.
The f/w ‘O’ for oem code means that flashing with official f/w may be a problem.
However COdeKings patched may be a different story.
As for teh SATA part you may in the short term need a SATA PCI Controller card.
Make sure it is flashable & has the SiliconImage Chip.

Hi Zebadee,

Thank you for the welcome and your quick reply. So as I understand for now, the only solution for this issue is to buy a sata Pci Controller card, or get my self a new motherboard.

If I choose to buy a new motherboard instead, what do I then have to be aware of? so that I don’t run into the same problem again?

Best Regards,
Michael

Where can i find TSST Win Inquiry 1.03.1 download please?

At Samsung ODD homepage. :smiley:
Goto Support ->DownloadCenter ->Check F/W version.

Hi :slight_smile:
Most of the newer boards will be OK.
Just decide on a budget. Plus the CPU type. Intel or AMD.
Have a look on a few sites.
Then come back & ask if not sure if your choice(s) are going to be compatable.

Hi :slight_smile:
Might try here.
http://www.samsungodd.com/eng/Firmware/FWvercheck/FWvercheck.asp

Found it thank you pinto2 :clap:

Thanks zebad i have not seen this f/w checker :doh:

In BIOS set SATA mode to IDE compatible.
(Reading motherboards manual first is always a good idea [section 2-25]:D)

BTW, don’t think you need a new mobo to get your S293B working.

Hi,

Concerning the latter: since your VIA SATA controller does not behave like a integrated IDE controller, you can’t boot from the drive for Windows installation. Maybe it helps to provide a driver floppy if requested (“Press F6 to install controller drivers” message). Have you tried with something else like a Knoppix CD? Also you should check your BIOS options concerning boot priority and the settings of your SATA controller. That [I]has to be set to non-RAID.[/I]

My motherboard is a : Asus A8V Deluxe Bios V. 1018.002
DVDWriter : Samsung SH-S203B Bios V. SH-S203B_SB00.bin
The inability of installing newer firmwares hooked on this controller is known for the 163 and 183 SATA drives.

Also I am confused about that the Oem Code is 0. It’s my second drive that don’t have the proper Oem Code. So it must have something to do with my motherboard. I simply have no clue about it.
See above and the FAQ.

Please help me solve this problem…
An idea, but I don’t know if it works:
After having made sure, your SATA controller is set to non-RAID operating mode, uninstall VIA’s SATA drivers. If you installed a recent version of the Hyperion Pro drivers, there should be an entry in “Add/Remove Software” in your Control Panel. Check (or uncheck) the VIA PATA and VIA SATA drivers to have them uninstalled and reboot. Windows should then install a generic “Standard PCI IDE controller”. After finishing installation, check all IDE channels, if they are running in UDMA mode, if not then this has to be corrected manually.
After that, run WinInquiry again and check if the OEM code is reported properly. Please report back the results.

Apart from this issue, the drive should work fine in general. Nevertheless, I would recommend to have at least one optical drive hooked up on one of your PATA channels.

Michael

When it comes to SATA early VIA chipset are crap.

[I]Edit.[/I]
I had to edit my post because there seems to be more then one versions of southbridges on A8V mobos.
Early versions use VT8237 and latest (like A8V-X) VT8251.

Hi :slight_smile:
It is my understanding that the 8V series from ASUS will not support DVDRWs.
Regardless of whether you install the non-raid or raid drivers.
It has two controllers one VIA VT8237 & the other PROMISE PDC 20378.

This tool is handy for me when flashing my Sammy’s. With all these drives i have i need to choose the correct one and this tool allows me to make sure i have the correct one. I hope :doh: :bigsmile:

Hi,

non-native speaker mode :wink: I thought, it was clear so. But I corrected it in my post.
On my MSI K8T Neo2, which is very similar (same chipset also), the BIOS allows me only to choose between “Disable”, “SATA” and “RAID” for the VIA SATA controller. That’s why I prefer mentioning “no RAID” instead of “IDE compatible” mode, since all manufacturers might use different terms.

Check manual
Too lazy :bigsmile:

or my post above.
Done. I suspect, the compatibility is not 100%

Michael

[I]Off topic[/I]

@mciahel, right now I’m in “more then five beers” mode. :bigsmile:

Note. My references above were for the latest versions of A8V. Had to delete them not to confuse because OP might have an older mobo.

If trouble updating the firmware from your system, you might try udating the 203b firmware attached to another system if one is available. That way you can also do a quick drive burn/test. That way when you move it back to your system you will be working with known good parts.

BTW I have a cheap (but not bad) motherboard. ASROCK 775Daul-Vista with only two sata ports. The 203b would run fine on this motherboard. BUT, for some reason it would not allow me to update the firmware…very strange. Worked fine on a silicone image chipset pci to sata card (about $20 at newegg). I got the Roasewell RC-209 it has one internal SATA port and one external e-SATA port.

On update…I have read some report problems with the auto update from samsung. May be better to do in manually…our local experts can chime in if I am wrong.

Dear CDFreaks,

First of all, I just want to thank all of you for all the great replies. I have spend a lot of time searching around to find a solution, but with no luck. And I must say I really do appreciate all your help.

I just tried to make a test file, to see how good it was a burning a dvd. And must say it looks pretty okay. DVD media I used for this is :

Intenso DVD-R 1x-16x
Disc ID: DAXON016S

I 01:09:14 ImgBurn Version 2.3.2.0 started!
I 01:09:14 Microsoft Windows XP Professional (5.1, Build 2600 : Service Pack 2)
I 01:09:14 Total Physical Memory: 1.047.788 KB - Available: 687.140 KB
I 01:09:14 Initialising SPTI…
I 01:09:14 Searching for SCSI / ATAPI devices…
I 01:09:14 Found 1 DVD-ROM, 1 DVD±RW and 1 DVD±RW/RAM!
I 01:09:53 Operation Started!
I 01:09:53 Source File: D: est.iso
I 01:09:53 Source File Sectors: 2.260.383 (MODE1/2048)
I 01:09:53 Source File Size: 4.629.264.384 bytes
I 01:09:53 Source File Volume Identifier: TEST
I 01:09:53 Source File Application Identifier: Derrow UDF/ISO Applica
I 01:09:53 Source File Implementation Identifier: Derrow UDF/ISO Library
I 01:09:53 Source File File System(s): ISO9660; UDF (1.02)
I 01:09:53 Destination Device: [2:0:0] TSSTcorp CDDVDW SH-S203B SB00 (F:) (SCSI)
I 01:09:53 Destination Media Type: DVD-R (Disc ID: DAXON016S) (Speeds: 4x; 6x; 8x; 12x; 16x)
I 01:09:53 Destination Media Sectors: 2.297.888
I 01:09:53 Write Mode: DVD
I 01:09:53 Write Type: DAO
I 01:09:53 Write Speed: 16x
I 01:09:53 Link Size: Auto
I 01:09:53 Test Mode: No
I 01:09:53 BURN-Proof: Enabled
I 01:09:54 Filling Buffer… (40 MB)
I 01:09:54 Writing LeadIn…
I 01:10:21 Writing Image… (LBA: 0 - 2260382)
I 01:15:21 Synchronising Cache…
I 01:15:31 Image MD5: c09886f9c91817786aa7ca36d9b870f9
I 01:15:31 Operation Successfully Completed! - Duration: 00:05:37
I 01:15:31 Average Write Rate: 15.119 KB/s (10.9x) - Maximum Write Rate: 22.107 KB/s (16.0x)

Now I just need to find a way to update the firmware from another PC… or just wait until I find another motherboard.

Best Regards
Michael

Hi,

Burning should be okay, even with the VIA chipset.

I 01:09:53 Destination Device: [2:0:0] TSSTcorp CDDVDW SH-S203B SB00 (F:) (SCSI)
The drive normally should not appear as SCSI drive, since the 8237 SATA controller is registered as IDE controller in Windows device manager if set to “no RAID” (IDE or SATA, depending on the BIOS settings available).
Have you changed the settings in BIOS?

Now I just need to find a way to update the firmware from another PC… or just wait until I find another motherboard.
What driver is installed for the controller at the moment?
Have you tried the method (using MS standard PCI IDE controller driver) I described some posts above?

cheers,
Michael

Hi Pinto,

The A8V deluxe I got does have VT8237…

Regards,
Michael