Samsung SH-222AL - faulty drives?

vbimport

#1

I bought a new Samsung burner: Model SH-222AL/BSBE, from newegg. I put in a music CD (standard commercially pressed CD), and it played (in Windows Media Player) with lots of distortion and noise, as if badly damaged. The same happened with about half the CDs I tried; all of them played fine in another (IDE) drive on the same computer, an audio player, and a laptop. I measured the transfer rate on one audio CD at 1-2x on this drive, and 10-20x on the IDE drive. I measured the transfer rate for one data CD at 7-8x on this drive and 16-20x on the other drive. Note: the other drive is very old, probably rated at 20x for CD reads. I did not find clear problems reading DVD media. I did not test writes, because I didn’t want to waste media. I tried a different SATA cable and a different SATA port, with the same results.

So I RMA’d the drive. The replacement behaves exactly the same (on the same half of my CDs). I did a little more investigation. If I ripped one of the problem CDs with Windows Media Player, it would rip very slowly, but the ripped file would play without the noise.

Does this make any technical sense??? Samsung tech support was no help. They suggested checking for a firmware update (my firmware is newer than what’s on their site). Otherwise I can RMA it to them, but the rep suggested ZRMAing to newegg instead. No interest in diagnosing any technical problem.

Newegg issued another RMA for a refund, with return shipping paid. So Ican return it and just be out the cost of the first return shipping.

Any suggestions for determining/fixing the problem? Any suggestions for a better drive to get? I don’t need anything fancy - just reliable playing, reading, and writing.

It’s a Windows 7 system, Gigabyte GA-880GA-UD3H motherboard, Athlon II X4 640 CPU.


#2

Hi and Welcome!

this could be an interface issue. If I remember correctly, then there are two Sata ports on the motherboard that can be configured as “IDE”. Make sure your drive is connected to such a Sata port. Also you might consider replacing the Sata cable.

Michael


#4

There are two SATA controllers on the board - one on the AMD SB850 chip with 6 6Gb/sec ports, and one on the Gigabyte SATA2 chip with 2 3Gb/sec ports. All ports can be configured as either “IDE” or “Native IDE”. I have tried ports on both controllers, configured as “IDE” or “Native IDE”. I have tried two different SATA cables.


#5

A couple more bits of data:

I also tried playing a number of audio CD-Rs and CD-RWs of various brands. I didn’t have any problems with any I tried.

On the discs that have problems, the noise shows up for the entire length of the disc (all tracks).


#6

An idea: are these CDs with distortions copy protected?

Michael


#7

[QUOTE=mciahel;2615586]An idea: are these CDs with distortions copy protected?[/QUOTE]
I don’t know a lot about copy protection, but I don’t think so. How would I tell? Everything I’ve found indicates that copy protected CDs began to appear around 2002, and these are much older (80’s and 90’s).

This failure seems rather counter-intuitive for a result of copy protection - playing badly degraded but ripping succeeds.


#8

This is really strange, and I have no additional idea :confused:

Michael