Samsung P370 screen edges not visible

Hi,

I recently bought a new Samsung DVD/Divx player - P370. Overall a very good unit, but I have one nasty problem with it.

When it plays video content, be it DVDs or Divx it stretches the picture too much and the left and the right edges of the screen are not visible. They are not cut off, I know because my TV has RGB centering feature and I can move the screen left or right. So I see the left missing parts of the movie when I move the screen to right and vice versa. I tested the problem through RGB and S-Video connection on two different TVs. I tried to get the unit fixed in the guarantee service, but the morons only held my unit for a week and then called me that it is ready. They explained that the issue is due to the video output setting NTSC and I should switch it to PAL, because we are in Europe. So I did and the problem remained absolutely the same. Anyway, I figured that I can find much smarter people here on this forum, please help me! My only remaining option is to turn the player back to service repair and loose another 2 weeks minimum. Or get my money back.

This is called “overscan” and is generally a function of the monitor itself, not a DVD player. The player is sending an image that is fixed in size, so it’s not really possible for the player to alter how it’s displayed.

Overscan is perfectly normal on ALL monitors, it’s there for technical reasons. As much as 10% is often seen. It’s true that PAL vs NTSC issues could affect this, but again it would be the monitor’s issue. Thee may be some other setting in your Samsung that’s affecting this, you’d have to sort that out yourself. The one that comes to mind is the settings for displaying anamorphic widescreen images on a 4:3 monitor. It if was set to zoom the image to fill a 4:3 screen, it would do this.

Hmm, my video output is set on 16:9 Wide (My TV is 16:9) as it should be, I tried all possible EZ view modes - Wide screen, Screen fit, Zoom fit (this zooms and cuts the picture even more - but that is normal), I even tried setting the player output to 4:3 Letter box, then the TV gets black bars on each side, but the same part of the picture is still missing!

When I put the same DVD movie in my laptop and plug it in the same TV, using the same S-Video input, I get the whole movie, as it looks on the laptop screen. If this picture loss is a function of all DVD players, then DVD players suck big time :slight_smile:

I didn’t say that overscan was a function of DVD players, I said the opposite.

I think you need to quantify the actual amount of image that is “missing”. Since you can demonstrate that the entire image is in fact present by adjusting your monitor, I’m 90% certain that this is an issue with your monitor. As I said, a DVD player supplies an image that is a fixed size, so it’s up to your monitor to display it correctly. Typically, a 16:9 film image will be 720x480.

I’ll also point out that using an Svideo connect actually rules out a 16:9 image being delivered to your monitor. Only 4:3 will be output via Svideo. For a 16:9 image, you must use either component or HDMI. So I suspect that your real problem is that you have things set up wrong. Your monitor is probably doing some “auto-aspect” adjustment that’s causing what you see. (like zoom or full-screen stretch).

To put it another way: (correct me if I’m wrong); you have the player set for a 16:9 monitor, but it’s connected via Svideo (4:3).

Not to mention that you simply cannot get a top-quality image via Svideo. Why are you not using component?

Ok, I will try to clarify further.

I cannot measure the ammount of picture loss, but I guess it is about 10 -20% tops.

My TV is 32 inch 100Hz CRT 16:9 Sony Trinitron model KV-32CS70K.
I have 3 ways to connect my DVD player to my TV.

  1. By RGB (with composite synchronisation) though SCART connector
  2. By S-Video (either through SCART or through dedicated cable)
  3. Composite Video (either through SCART or through dedicated cable)

The TV is European model and as most of them unfortunately does not have component video. And it is not expensive enough to have HDMI. Not that it would do any good as the player does not have HDMI either.

So, my first choise is RGB as it is best quality and does not have the “only 4:3” restriction you mentioned. Only in this mode my TV has the “RGB centering” feature that I mentioned. But it does not allow me to shrink the picture, which could solve the problem. Only to move it right or left. The issue shows in RGB exactly as in S-Video. I have not tested composite video as it is too low quality to consider using.

And yes, the TV uses all the usual tricks to get 16:9 picture out of S-Video, the so called Anamorphic Video that is basically 4:3 stretched vertically so it can fill the 4:3 signal with more resolution. Then the TV flattens the signal back into not bad 16:9 image. The TV can also use letter boxed 4:3 signals that it zooms and gets worse 16:9 image with visible horizontal lines. The point is that with RGB the TV does not need to do that. And even if it does, this does not mean picture loss. Because as I said my laptop is connected on the very same S-Video input as that I tested with the DVD player. And the picture is OK, so I think that rules out the monitor as the source of the problem. I also tested with another very different 4:3 TV a I got the same results.

I never needed to adjust anything on my TV image position or size using two different PC to play movies (Through S-Video). The only reason why I got the stand alone player is because of the RGB connector. Anyway this is a TV, not a computer monitor and there are not such options available even on this relatively high end model (well, maybe in the service menu, but I not intend to touch that). So, I still believe that stand alone players should not eat parts of the picture and my partucular one is setup and configured in the best possible way.

I don’t know what else can be said except that your monitor is the problem, not the player. The monitor is getting the WHOLE picture, as you already stated.

Well, it does obviosly but it does not display it properly :slight_smile: I was kind of hoping that someone can explain that. How can my TV get the whole picture from two different sources of the same movie and to display one properly and the other zoomed in? If my monitor is the problem do you suggest that it somehow detects who is sending the picture and if it is the laptop or my desktop PC it goes “Ok, I will show that properly”, but if the DVD player sends it “I will mess that up”? Sounds strange to me. Maybe my TV hates my player?

Is it not possible that the player sends the image zoomed in and with higher resolution that it should? The RGB centering that shows additional picture maybe shows exactly those additional lines of resolution that the TV cannot possibly display if they are outside the supported display resolution.

Maybe some aspect ration calculation goes wrong?

I will try now and test with some DVD that is exactly 16:9. If horizontal lines are also lost that will prove that the picture is zoomed. If not, then it must be with wrong aspect.

Yes, there is some picture loss horizontally as well, the aspect is correct, circles do not seem eliptic. So the image is just zoomed in. Something like the Nvidia full screen driver bug. I hate this kind of stuff.

I though I already did explain. It’s called overscan, and ALL CRT TVs do it. Many LCD’s and projection sets do it to, but it’s individual according to the maker’s wishes. It may be adjustable in your TV, but usually requires a technician to get inside to do it.

Once again, you are not sending a 16:9 image to your monitor, but a 4:3 one. In this case what you see may be the result of the way the monitor is stretching it to 16:9. But it has nothing whatsoever to do with the DVD player.

Yes, I did some research on the issue and found about the overscan. Bad thing, maybe my laptop ATI card driver does something to fix the issue and that is the reason why I see the image correctly from there. From what I found I have two options.

  1. Buy a better DVD player with underscan feature.
  2. Go inside my Sony service menu and try to remove the overscan.

Thank you CDan for your information and assistance!