Same problem for 2 years HELP!Involving HD/DMA/PIO slow burning,etc!

vbimport

#1

Ok I’ve read 1000 threads on the DMA/PIO problems and tried a ton of solutions but still have the same problem.First off my pc specs:

PIII 1ghz w/384mb ram
Nvidia geforce 3
Mitsumi cdrom drive
Lite-on LDW 411s@811s
Hard-drive is a Maxtor 5T060H6 60-gig HD

I noticed around a year ago that with a 52x cdrw burning at 40x it took me 15 minutes to burn a cd, wayyy slower than it was supposed to.Tried everything in the book new drivers, firmware, programs, etc.Never got it to burn right.Then bought a dvd-rw dual drive.Same thing takes me 45 minutes to read/write a dvd using dvddecryptor.I am not running much in the background.My primary IDE master is my HD and for the life of me I cannot enable DMA, when I select it in the device hardware section it stays on PIO mode.There is no slave it’s all by itsself on that cable so that’s not the problem.And I looked up the HD and it is DMA compatible.My dvd-rw/cdrom drives use a 40-pin cable, while the HD is connected with a 80-pin.Hope that sounded right kind of winging it here.While my secondary IDE master/slave(liteon 811s/mitsumi cdrom) is on ultra dma.I have tried uninstalling the primary IDE channel and re-booting to hopefully allow DMA, no go.Tried switching the IDE cables manually, then none of the three allowed DMA, then I tried the regedit commands, still NO DMA.I am sick of this my burner takes 45 minutes to 50 to burn 1 friggin dvdr.I’ll PAYPAL someone some $ if they can help me get this fixed, I’m begging.I know I sound newbie-like which I sort of am.I can generally fix my pc problems but so far I’m stumped on this one.I have searched the forums none of the other threads on this topic helped me.Hopefully one of you guys that has the know-how can help me out here.Every burner I have put in this sucker since buying it burns slow as hell.It’s gotta be the DMA setting on my HD right?Any help is greatly appreciated.DYING…


#2

If you’ve already read tons of threads on it I’m sure you’ve tried the regular old tricks.

So,
Your best bet would be to try a different hard drive. Even and old used one, or one that you can return to the store or something.
If you can enable DMA on it with the same system setup then it’s a hardware issue with the original drive.

If the problem exists on both drives,
I would try mothboard BIOS updates. If that didn’t work I would back up the system and re-install the OS.