Safedisc 2.9--can we cut to the chase plz?

Greetz.

Short and sweet.
xppro
amd 2100
tdk 24/10
liteon52/24
sams dvd 16x
lots of hdd’s

Have used CCD4. Like it. Burnt all past archive copies with it. Have BF1942 Secret Weapons. Tried all known setting for SD in CCD. Install, but no worky. Tried alcoholer (newest), no VD install. Could not even run that, and now game insists it will not work (original cd). Am now going to try BW. Have run through preliminaries. Tried 5 times. Cannot get it to work. Have read a multitude of forums and guides.

Have searched the forums. Lots. I do not like to post fresh to find an answered answer…BUT…

Can we get the BW thing in writing from an authority? There seems to be a dozen different ways with that many different results. So, here is what I see when I use BW.

With SD2.9, first read cd TOC. Can do that.
2. Two check boxes. 1.) Authorize use of alternate read method and 2.)Extract subcodes…I tried to download the manual from VOS website, was not there. So, WHAT do these two do? And what should be done with them?

  1. Image output? One post said perhaps not BWA, but is BW? format good? Or should iso or something else be used?

  2. Extraction method. NIBBLE OR MULTIPLE GAPS? What are they? And what should be used? I have tried both, and after 4 hours, nibble never did get an image. MG did after about 30 minutes, but burn came out unusable.

  3. For burning, got 1.)Autoplay–like a cdr media check or something? 2.)Enhace weak sectors–yes or no SD2.9? 3.)Eject when finished…does this do anything other than what it says? 4.)Aspi layer…does it matter which one? 5.)Associate file extension…have anything to do with a succesfull copy? 6.)Allowed write modes…what to use, have read DAO PQ or PW… any ideas?

I know enough to use a slow read and usually a slow write. Does this still hold true? Have also read that some burners are now incapable of reading and writing new protections. Is that it then? Throw away and get a new one? And, have read that it is sometimes better to burn to a cdrw instead of a cdr or even to a colored disc (black or green or so), is this true? What about playing in a cdrw drive vs. a dvd/cd-rom?

I just spent 2 weeks searching and trying to copy this new game that I want to shelve. I tried virtual drives and found out rather quickly that EAgames now dictates what software I can have on my computer if I want to use thier games. I understand the anti-theft stuff, but this is going a little far, esp for legal buyers.

I am trying BW because Alcohol does not like my rig I guess.

Is there a definitive system that anyone is willing to share?

Thanks in advance.

Hi,

I dont know about thw capabilities of the sams dvd 16x so we’ll stick to using the liteon52/24 for both reading/writing

Safe Disk copy protection does not need a BWA created…You do not need to extract subcodes either

Right so lets get into it.

  1. If your liteon52/24 allows the use of alternate read method use it, other wise leave it blank. (For Safedisk Only Games)

  2. Use Nibble - Set the read speed between 1x - max

  3. Remove tick from enhance week sectors

  4. Write the Cd with DAO-PW (with autoplay either on or off - though i recommend on)

JP

If the original does not work either, make sure you turn off CloneCD’s ‘hide CDR media’ option, and get rid of CloneCD’s virtual drive by uninstalling and re-installing without selecting that option.

Obviously if the original won’t work then how do you expect a back-up copy to?

Lazer.

Allrite, I have a fresh install of xppro with nothing but blindwrite on. On the prior install, I had ccd4 with the hide cdr media checked. Upon installing the game, it worked fine. When I used ccd4 to try a copy, the copy was a no-go, but the orginal still worked. It was only after I tried fantom cd to see if I could use an image that it quit. Then I tried Alcohol. Disabled the VD in that, but it never was able to run stable. Then I removed both, and the game still did not work. Removed ccd4 and game still no work. Scoured registry looking for the key that would unlock it again. Never did find anything that looked promising there.

So now I have xppro fresh, with only blindwrite on. I have used the liteon in the past with everything. I tried it with the alternate read method on and off. If I use nibble it takes forever. If I use MG, it finishes in 1/2 hour, but does not seem to work. I have enweaksectors unchecked. After 3 hours nibble was still working on the end section of bad sectors. Just let it run then, no matter how long it takes?

Thanks for the help.

Later.

Yes, it would be best to let it go. Personally, I use alcohol’s fastdump when backing up safedisc games - these bad sectors will fly by in < 5 seonds.

There was quite a few threads on the CloneCD forum about this game copied using Alcohol 120%.

As andareed says, make sure ‘skip reading errors’ and ‘fast skip error blocks’ is ticked whilst reading.

Have you tried writing with the ‘Bypass EFM error’ option unticked? (By default, this is the safedisk option as opposed to the safedisk 2 option).

The threads on the CloneCD forum suggest that they were even able to play from Alcohols Virtual Drive too after doing this.

Again, make sure that CloneCD ‘Hide CDR media’ is NOT ticked, and if you play from your Lite-ON then you’ll need to tick the ‘Ignore media type’ in Alcohol 120%.

Lazer.

Well, put Alcohol back on this OS install. Seems to work fine now. Tried one image last night, forget all the settings. Used protected cd I think. Got the image, but burning has not been going so well yet. Just read a few more things, tried this:
(checked) skip reading errors and fast skip error blocks, and that was it basically. Read of max, although it is reading at 0.5x now. Seems that there are a lot of bad sectors in the very beginning, and then a lot at the end. Been reading for 30minutes now and only 50%done. 275mb @ full speed was done rather quickly, and now waiting.

Any thoughts with Alcohol regarding reading and this horrible wait? BTW, next I try Andareed’s fast dump.

Later.

You should not see any bad sectors at the end if it is safedisc - only sectors between 100 - 11000 should be errored.

At the risk of stepping out on a limb here, I have scanned the disc with clony it says SafeDisc 2.9 and thats it, now if I scan the the exe in the battlefield folder, whether with yates, yaps, or safedisc analyser or scan the Battlefield 1942, The Road to Rome or even the Secret Weapons exe. they all report no protection found, but if I scan those same 3 exe with Protection ID it clearly states that the exe are encrypted with PeX, I have been searching and not found much other than it is an exe wrapper/encryption. It would appear to me that EA as well as JoWoods (Slovak protection) are using these as well as popular protections to protect their product, so they are doubleing up. I was able to back the Game up tho using Blindwrite 4.5.7.49 and BlindWrite 5 (still in testing) All I did was read at 4X and use default settings with the exception of I used Auto-Play. I used auto-play because a setup and run a game server that only has a cd writer in it, I also have the standalone autoplay filter on the server but NO burning software. The back-up works and I can use it to run my server.

Well, I can tell you that with both BW and Alcohol it does indeed find bad sectors at the end. And what is more, it finds a LOT more of them. You are correct in that the beginning has like 10000. There must be at least 50000 on the end. This is BF1942 Secret Weapons that I am talking about. I have read a LOT of images now. Nothing seems to burn successfully. I have taken all advice and tried all settings (I think anyway). So, if I try the latest BW, and just read it with perhaps autoplay checked, and nothing else checked, at 4x or below, that has given a working copy? But you did not mention here if the burning process was all at default and at what speed.

It is interesting to note that there are perhaps 2 protection schemes here. I do not consider myself a n00b at this stuff, but I am completely at a loss right now.

Keep pumping me with info though.

Thanks.

Originally posted by denali
Well, I can tell you that with both BW and Alcohol it does indeed find bad sectors at the end. And what is more, it finds a LOT more of them. You are correct in that the beginning has like 10000. There must be at least 50000 on the end.

Slow down your reading speed if you’re getting read errors after the first ~10,500 sectors.

If you’re getting thousands of read errors at the end of the cd it’s no wonder you can’t get a working back-up since your image file must be bad.

denali,

Try scanning the original disk with NeroCdSpeed_2.02 using the Extra->Scan Disk->Surface scan option? You’ll probably need to have ASPI 4.6 installed btw.

SD protected CDs usually have the first sector OK followed by a whole bank of (red) unreadable sectors along the first line, then the rest of the CD should show OK (green) sectors. If you’ve done a few images in the past you must be pretty familiar with that sort of pattern anyway?

It either sounds like a new form of protection if there are unreadable sectors (lots of em) at or near the end of the CD, or maybe the disk is faulty? Seems strange that nobody else seems to have picked up on this. Is it a UK/EU/US CD?

kamikazee,

BF 1942 patched to 1.2, and Road to Rome seem to be SD2.8, but then maybe the USA version is different. You seem to have a lot of ‘unique’ ‘happenings’ on your system from what you were saying on Messenger wink wink :wink:

Lazer.

Right then. Reading at 1x produces this event. CCD4, which is what I initially tried to copy with took an unusually longer amount of time to copy it. Of course I tried burning it off with that, but no go.

So then the first thing I notice with BW is that no matter what setting I use, after it has gotten the bulk of info in, like around the 275mb mark I think, it goes into error mode for a LONG time. Continues to add mb to the total for perhaps 75mb more. I believe that by then it has had so many errors and has been so long, that it must find the end and then bang! it is over. Alcohol showed the same scenario. Even at read speeds of 1x, those errors are at the end. One lesson I learned straight away was that to create a 1:1 copy, just read it slow with the right settings and it will give a spot on copy. And burning at no greater than 4x has been good to me so far.

So, I have 11 images now. I am getting a headache with this one. It is a US version of sectet weapons I assume as I live in the US. I will try the nero tool tonight and report back what I find.

Keep pumping the info please.

OK, here is the readout on cdspeed. What do you make of this?

Later.


BF 1942 patched to 1.2, and Road to Rome seem to be SD2.8, but then maybe the USA version is different. You seem to have a lot of ‘unique’ ‘happenings’ on your system

When Secret Weapons is installed it encrypts all three executibles with Pex, at least here it did. There is more going on with this version of safedisc then there has been in the past.

Originally posted by kamikazee
When Secret Weapons is installed it encrypts all three executibles with Pex, at least here it did. There is more going on with this version of safedisc then there has been in the past.

Yes, apologies, that does make sense kamikazee. :slight_smile:

denali,

The top line looks like ‘classic’ Safedisc, the rest looks a mess!

There doesn’t seem to be any ‘pattern’ to it. Can you read all the files using the same option but instead of ‘surface scan’ choose ‘file test’ with no errors reported?

If not maybe the CD’s faulty, if you can then this is a weird looking protection.

You have got an up to date ASPI layer?

Lazer.

Just for comparison, here’s a NeroSpeed surface scan of IGI2 disk1 original (SD2.8).

Anyone have a scan of a SD2.9 original CD (preferably BF1942 Secret Weapons) ?

Lazer


I don’t know if it can help someway, but I had the same problem with “New World Order” spanish version. It was Ring Protech according to Portmac… and probably a new version could be out there, or a mix with SD :confused:


here is one of my Secret Weapons of World War II

@denali: Does your original actually work? From this pic, I would suspect that cd is damanged.