Safedisc 2.9.040 original stopped working

vbimport

#1

First my writer is a new Liteon SOHR-5238S (52x32x52s firmware 4S03) my primary reader is an OEM Compaq 40X, model SC-140 (which I believe is actually Samsung which shares the same model number). I also have on hand a Cyberdrive CW068D burner, a Toshiba 6501B CDROM, and an old HP 8100 CDRW. I’m using Windows 98SE.

Here is what I am trying to do, backup Splinter Cell and NFS Underground (both SD 2.9.040).

I haven’t done game backups for a very long time so I reloaded my old tools, CloneCD 4.2.0.2 and Daemon Tools (I forget which version). I read that CloneCD alone doesn’t work very well with Safedisc 2.9 so I used Fireburner to write the backups. Backups didn’t work. Originals no longer worked either!

When I discovered the latter I figured the games blacklisted the tools so I uninstalled CloneCD and Daemon Tools. Splinter Cell was once again working, both the original and backup.

I then reinstalled CloneCD but WITHOUT the virtual drive. Splinter Cell stopped working again, backup and original! Sorry to repeat myself, I don’t have any virtual drives installed!

Worse, NFS Underground has permanently stopped working.

I’ve made sure CloneCD and Daemon tools are completely removed from my system, all files deleted, all references are removed from the Registry. The game still refuses to work. (Please note that prior to this incident I had been playing NFSU for nearly a month).

Additional problems

Without being able to installl CloneCD I can’t use “Hide CDR”.

Daemon Tools doesn’t actually figure in my original problem but I noticed that the Spinter Cell image doesn’t work while the backup disc does. I assume I probably need to update Daemon tools? (I forget the version number but it is at least 1.5 years old).


#2

It cant be a issue with blacklisting, as that was only introduced into SD3.
If your version of daemon tools is 1.5 years old then you definatly need a update and one fast.
What other programs have you got installed?


#3

Do you mean games, game backup tools, burner software, whatever?

I don’t have anything other than CloneCD, Daemon Tools, and Fireburner for game backup software. All my trial versions of Gamejack, Blindread/write, and others expired.

Nero 5.5.10.xx and MusicMatch Jukebox are the only other burning software I use.

OK so no blacklisting but this get stranger and stranger. I’ve done some more testing and I’m even more baffled today.

Yesterday, I uninstalled and reinstalled a minimum of 3 times each, the two games, CloneCD, and Daemon tools. Got the same results every time.

Today, nothing is consistant. I install the Compaq CDROM (master, Cyberdrive CDRW is always the slave). Splinter Cell backup works. I install CloneCD the Backup stops working. I uninstall CloneCD the backup once again works. This is without virtual drive so there are no drive letter reassignments.

I try the same thing with the Liteon CDRW, install it as the master. As expected the backup does not work because CloneCD and Hide CDR are not available. However, this time I install CloneCD and the backup works but only with Hide CDR disabled. Enabling Hide CDR does exactly the opposite of what I expected/hoped. The backup stops working. This was a one time freak occurence for me.

I start this step over again and uninstall CloneCD. I can’t reproduce the same results. The Liteon plus backup copy don’t work (again expected). Reinstall CloneCD and this time the backup copy doesn’t work no matter what I do. This just gets stranger and stranger!

I’m ready to just give up except…

NFSU is completely non-functional. It never even checks the CD/CDRW drive for authentication, just “program error…”. I tried reinstalling NFSU to no avail. This game was working prior to my attempts to make a backup copy.

I’m beginning to think I have two separate problems.

  1. The weird issue with my Splinter Cell backup, which I’m perfectly happy to leave in it’s current state. I have a backup that works on one drive.

2)Some sort of corruption with NFSU, which I need to resolve.

I’m going to try installing NFS:U on another computer to make sure I don’t have a damaged original.

A confused Phsstpok.

p.s. I’m putting this aside for the moment while I attempt to backup my nephew’s Motor Racer 3 (Tages). He’s got that disc all scratched. This problem is probably going to give me even more trouble! LOL hysterically!!!


#4

Hi phsstpok,

first of all why don’t you use just one of your readers for playing the backups and no CDRWs. The readers can’t read the atip of them. Anohter way is mounting your images with the newest daemon tools version I think it’s 3.46.
Download the profiles for CloneCD CloneCD 4 Profiles for Download ! and try the SafeDisc (1/2/2.51) - no AWS
profile for NFS underground. If this is not working try SafeDisc (2/2.51) - AWS profile. You can also get some other profiles here try them if the others are not working. Mount the Image with daemon tools and enable SafeDisc emulation, should work. About your HIDE CDR media, stuff there is a thread at cdfreaks how to uninstall CloneCD keeping this option alive but I didn’t find it.

p.s backing up Moto Racer 3 you won’t have any luck until using this fantastic TOOL and patch the CloneCD Image using it :slight_smile:


#5

Kalas, I will try the newer Daemon Tools. Thanks.

As for using a reader vs a CDRW, I probably will do just that. Sure, it’s a nuisance to uninstall CloneCD just to play the game but then I only need CloneCD when I want to make a new backup. If the backup is successful I only need use CloneCD once.

Regarding Safedisc Profiles for CloneCD. I already tried those the results were coasters when attempting to backup Safedisc 2.9. The only success I have had was using CloneCD to read and Fireburner to write.

And for Tages I downloaded some utillities but they only run under Win2K and XP. Unfortunately, I am using Win98SE. I’ll look at the utility you suggested.

I still need to figure out why NFSU is broken.

Thanks again.

Phsstpok


#6

Hi Kalas,

Thank you!!!

The update of Daemon Tools helped a great deal. My Splinter Cell backup now works with my CDRW drives (with Emulation) and the image plays in DT’s virtual drive. This will be a great help. Not being able to verify images was making backups difficult.

I still don’t know what caused my problems with NSFU but downloading patch #4 corrected it. I’m perplexed as to why the game worked for nearly a month then suddenly stopped recognizing the CDROM. Even a clean re-install of the game wouldn’t run.

Anyway, the game is working and that’s a relief since I didn’t finish playing it.

The backups of NSFU still don’t work at all but I’m making progress. At least I know the image works.

Strange that backing up NSFU is not as straightforward as that of Splinter Cell. Both have the same protection. Perhaps I goofed a setting in Fireburner.

Thanks for your help. Thanks for everyone’s help.


#7

Splinter Cell is safedisc 2.80.011 ; NFSU is safedisc 2.90.040, which introduced 2 new problematic weak sectors. That’s probably why the NFSU backup doen’t work. Try playing from your liteon burner (you will need to hide ATIP) , as liteon drives are better at reading badly burnt weak sectors.


#8

I think you’ll find that blacklisting has been around for a lot longer than SD3.


#9

Happy to read that it’s working for you phsstpok :),

by the the tool for Moto Racer 3 is just for this game it won’t work with any other Tages protected game. As far as I remember you have to make an Image using CloneCD and patching it with the tool. I think there is a exact description included in the download but I’m not quite sure.


#10

Scanning -> E:\games\Splinter Cell\system\SplinterCell.exe
File Type : Exe, Size : 1079393 (0107861h) Bytes
-> File has 845921 (0CE861h) bytes of appended data starting at offset 039000h
[!] Safedisc 2.90.040 detected !

  • Scan Took : 0.718 Seconds

Is ProtectionID v5.0 always accurate? I don’t know. First time I used it was with these two games.

This is the Thailand version of Splinter Cell if it makes a difference.

After patching NFSU I started over again. Using CloneCD (v 4.2.02) with Safedisc 2+ profile (no AWS) and Fireburner, I made a working backup but again I’m confused. It works in my CDROM drive without emulation but with my burners I need to turn on emulation (Daemon Tools 3.46). Strangely, I don’t need Hide CDR.

My image works in DT’s virtual drive but not in CloneCD’s.

Phsstpok

[Addition]
What I have now has resolved my issues. NFSU is fixed. I have backup copies of both NFSU and Splintercell which work in multiple drives and I don’t need emulation (as long as I use a CDROM). This is all I ask of my backups.


#11

You scanned the exe with pid before or after patching? Because when patching the game the protection normaly changes to a higher version. I hope Protection ID is an accurate scanner :p. You can also try aray scanner www.aray-software.com and scan the directory for the SafeDisc version if you don’t trust pid. They work on Daemon Tools virtual drives because they aren’t blacklisted.


#12

I don’t believe I ever patched Splinter Cell.

I tried scanning the discs but the validation executable must be encrypted because no protection was detected on any of the discs.

I never really finished the game but it’s been so long that I might as well start from scratch. I’ll reinstall it and see what protection I have. I never knew that the protection could be changed with updates.

Oops, I missed a couple of posts. Did my original NFSU blacklist CloneCD? It sure seemed that way to me.

Thanks again, kalas.

Phsstpok


#13

If you want to scan whole CDs use aray scanner, for scanning .exe and .dll files use pid phsstpok.


#14

I tried A-Ray Scanner. You were correct. Splintercell Disc 3 contains Safedisc 2.8.

All is well now. Thanks for your help.

Phsstpok


#15

You will find that in many games, updating the SafeDisc protection scheme isn’t all that common, not as much as SecuROM updates.


#16

The utility seems to be for Alcohol 120% images only. I only own CloneCD. Is there a utility to convert images between formats?

Phsstpok


#17

Download the trial version, that’s the only way to get an Alcohol Image :slight_smile: