Safe to downgrade to an older firmware ? (1008IM)

Hi, i wonder if it’s safe to downgrade to an older firmware of 1008IM…because first when i got my burner i could burn 4X on 4X Medias … but ever since i upgraded the firmware, i’m not able to do this…the newer firmware disables the DMA, and there’s NO WAY i can enable it.

Firmware has nothing to do with enabling or disabling DMA.

  1. Make sure your burner is jumpered correctly (no cable select).
  2. If you’re using Nvidia Nforce IDE drivers, uninstall them and use Microsoft drivers instead.
  3. If you have Intel Application Accelerator, uninstall it!
  4. Make sure DMA is enabled in your system bios.
  5. Make sure DMA is enabled on your IDE channels in Device Manager.

Thanks for the reply…when you say Intel Application Accelerator … do you mean http://www.intel.com/design/software/drivers/platform/inf.htm <--------this one ?

And i have Nvidia Geforce 2 MX/MX … does this include Nforce IDE drivers? how do i install it ? thnx

No, I mean
this one --> http://downloadfinder2.intel.com/scripts-df/download.asp?url=/4625/eng/iaa222_enu.exe

An Nvidia graphics card has NOTHING to do with IDE drivers. Some motherboards use Nvidia Nforce IDE chipsets/drivers.

Okay, thanks…then i think my MOBO is the problem…but it support UDMA…i just don’t understand why it doesn’t want to enable DMA on my DVD-writer. And i’ve done all the things you said above.

Throw your burner on Secondary master without any other devices. (with jumper set correctly)
If this doesn’t allow you to reenable DMA, try swapping out the IDE cable.

I already have it on my Secondary master, alone…and i’ve tried to swap the cables too…i bought a ATA 133 cable…still no changes…

Try to uninstall the secondary IDE in Device Manager, and after do a Refresh (it will install again the secondary IDE).
Then enable DMA if it isn’t already enabled.

Already did that 100’s of times…no luck :frowning:

Update your IDE drivers and reboot.
What is the EXACT make and model of your motherboard?

How do i do that ?