S203B reporting as SSB00

So… My samsung S203B is reporting as an
“SATA TSSTcorpCDDVDW SSB00” in Winquiry (see attached)

When I try to update the FW… it says that no supported device is attached or something along those lines…

I’ve tried both AHCI and IDE mode on my jmicron controller… I noticed someone else had this problem in this thread:
http://club.cdfreaks.com/showthread.php?t=227513&page=2#post1904226

but it appears it has to do with the jmicron controller… I’ll switch it over to the ICH9R controller tomorrow and see if it fixes it…

is there any way to force a flash?

Welcome aboard! :iagree:

That was me with that problem and I solved it by installing the affected drives in another PC, also on a Jmicron controller, but for some reason no winiquiry or flash issues there. Hopefully you will find success in switching the drive to the Intel controller – at least long enough to make the flash.

:slight_smile: Welcome to the forum ManiacDC!

Try switching over your drive first to the ICH9C controller. :wink:

Oh, I thought I had responded here, I guess I hadn’t. Switching it to the ICH9R worked, thanks for the responses.