RPCDE - a fix to the ASPI bug!

Hi

If you’re one of those having problems running RPCDE in WinXP/2K, there’s a fix to the aspi bug.
It should now run fine without ANY aspi installed!
Please download at this temporary page unzip, test and report.

Thanks in advance :cool:

Sorry, but non-html files may only be downloaded if linked to directly from the site hosting them. Please scroll all the way to the bottom of this page where you will find a link to the file you are looking for.

ok its workin now

altho i did not have aspi problems I tested it
all is as should be for me

Ok Googydave,
Thanks for testing&reporting! :cool:

I’ve made a temporary page now, to make the server happy… :bigsmile:

Cheers :wink:

This seemed to work. I tried it on my 166s. How can I be sure it worked?

http://www.cdvdinfo.subnet.dk/cdvdinfo.zip will show you status of drive

I am unable to access that page (Forbidden) but I will search for cdvdinfo .

I uploaded the file onto my webpsace @ http://www.lexicon.net/goofydave/RPC1/cdvdinfo.zip

Hmm it is still locked.

I ran RPC 2 and selected the DVD and got a success message

Then I rebooted and checked with the info tool and it is still locked

OMG I am such an idiot… I want to choose DISABLE not ENABLE
OKay I disabled and am rebooting. (my dvd isnt showing up using the cd info tool)

your first screen shot shows Enabled RPC which means u clicked Enable … you have to click Disable for it to change it to region free

http://www.cdvdinfo.subnet.dk/ seems to load fine… then it forwards to musiccollect.dk

you might also like to know ntloser that DS0F firmware is out for the 166S @ http://www.jlms.com.tw/download.htm

And 1 last note. everytime you update firmware you have to run the RPC program again to disable region protection

UGH I cant believe I was enabling it … I figured that out after a while… I now have 5 times to select the region instead of 4

Ntloser,
Thanks for trying but you still have to enable W98compatibility mode for Rpcde.exe if your OS is Wxp/2k.

Once you’ve done it and run it you might get an error regarding ASPI. This is what the bug fix all about!!!

Enable W98 comp mode for RPCDE2 and try again please.

Read my Region free page for detailed instructions.

u know Mango I havent had to put it in compat mode 98 myself
on winxp

altho i have used forceASPI to install ASPI 4.60

Originally posted by goofydave
[B]u know Mango I havent had to put it in compat mode 98 myself
on winxp

altho i have used forceASPI to install ASPI 4.60 [/B]

If you mean Rpcde2 didn’t need compat mode as opposed to Rpcde - that’s VERY interesting!

The guy that found the bug and fixed it say it was about the aspi prob and the reason was a wrong buffer allocation for Wxp/2K, so it could have been causing this too.

Since I still run W98 I depend on good people like you to do the testing :wink:

Could you maybe repeat it without aspi and without compat mode? It should be done about this way:

  • enable rpc again
  • run Dumpaspi.bat to back up your present aspi layer
  • run Killaspi.bat to get rid of the aspi layer
  • reboot
  • run Rpcde2 without comp mode and press the “disable” button

If it makes your drive region free this way, we have a real winner here!!!

After that you may run Restaspi.bat to restore your original aspi
layer.

If you’re willing to do that I’ll be awfully grateful to ya :cool:

TIA :wink:

Awesome… Rpcde 2 worked without using compatibility mode. I installed the latest ASPI and rebooted. Then, I updated the firmware on all CD/DVDs and rebooted. Upon reboot I ran RPCDE.exe and it didnt work. In fact, after installing ASPI, RPCDE couldn’t see any of my CD/DVDs in 98 compatibility mode. I ran RPCDE in regular mode and chose DISABLE but the DVD still showed up Region locked. I tried RPCDE2 in 98 compatiblity mode and my CD/DVDs weren’t detected. Finally, I ran RPCDE2 in regular mode and viloa:

Yehow!

Great job Ntloser, thanks!

Ok, 2 more things:

  1. Many thanks to Chris who found the bug, fixed it and let us have it :cool:

  2. I made a bit of a cosmetic improvement, hoping to eliminate the disable/enable confusion, which has happened to quite a few.

This improved “version” is just up on the server. Have a look.

cheers

I tested it by removing aspi layer and it becomes region free :slight_smile: