Roxio wont detect my external cd drive

vbimport

#1

I just installed roxio easy media creator 10 to my computer today, and everything went perfectly smooth and i actually successfully burned 3 audio cd’s using my external dvd rw drive that i have connected to my laptop (which was marked as “drive G” by both windows and roxio.

After i burned the 3rd cd, i attempted to burn another cd, but for some reason it froze up and i had to end the program. As soon as i started roxio back up, my “G” drive disappeared and it only recognized my regular cd drive thats on my laptop (drive “E”). My external dvd rw drive is recognized by windows, and i can find it in My Computer as well as device manager just fine.

Can someone please help me out here? I researched this a little and tried intalling the px-engine patch from a couple different web sites but that did nothing. I also tried uninstalling and reinstalling but that did not work either. This whole thing is a joke and i am about to smash my computer because this is the most ridiculous thing ive ever encountered, and for it to just stop showing up is beyond me.

I am currently running windows 7 and my external dvd rw drive is an HP lightscribe 1040r if that helps anybody out. Please help!


#2

Hi,

have you tried other CD/DVD writing software, like ImgBurn for example? Perhaps this could help to narrow down the problem.

Michael


#3

no, i dont have any other kind of burning software. But i did try to just drag the mp3 files from the “E” drive to the “G” drive in My Computer, and for some reason it didnt work, it just froze up and did nothing so i had to close it.


#4

Then please try ImgBurn. In case the burning process fails also, then you have a log you can post and experienced members can have a look into it.

Michael


#6

Ok thanks i think i’ll try Imgburn. Whats really messed up though is that if i put in an audio cd in my “G” drive and try to add tracks to the playlist before i burn the cd, my “G” drive is actually detected and i can put the audio files on the playlist and burn it to a blank disc in my “E” drive just fine- but i cannot burn it to a blank disc in my “G” drive because it does not even show up as an option, only the “E” drive like i was saying earlier. What a joke.

It takes twice as long to burn a cd using my standard “E” drive than it would to use my external dvd rw drive (“G”), so i am a little frustrated that it would just disappear like that, but nontheless it still works…