RitekG04, standalone player freeze

Hi all,
I finally decided to open this thread since I am completely lost with my DVD burner (emprex 1004).

I only use Ritek G04 DVD and I usually can burn good DVD (That is to say, DVD that my standalone player (LG) can read perfecly).

But now it seems everything goes wrong. My 4 last burns produces some freeze during movies on all DVD player except the 1004…

-Standalone player (LG) gives some freeze.
-Pioneer 106s player gives some freeze.

I decided to test my burned media with Kprobe, you can state results from attached files.

So results are different while the burn process is the same !!:frowning: :frowning:
DVDs are ripped with DVDshrink 2.3 and burned with nero.
What’s more, this problem never happens with a DVD-RW (TDK burned at 2X)

I have tried :
-update 1004 firmware from 039 to 048
-Nero 5.5 and 6.3
-Disk defrag
-change IDE chanel (HD and burner on different chanel).
-Burn ritekG04 at 2x (worst case !!! image and sound freeze every second !!)

I am searching for a solution on this forum for 2 days now without succes.

Can somebody help please ?

I feel like I’m becoming crazy
:confused:

plese do a 4x8ecc scan and do NOT check max

Originally posted by Spidy1000
plese do a 4x8ecc scan and do NOT check max

Thanks for your quick answer !
Hereafter the new graph with requested settings.
Regards


seeing that scan i think you should return it to the shop you bought is if you still have guarantee

I never saw scan @ 4x8ecc with that high PI/PO

get a refund or get a new drive

Thanks Spidy1000 !

Before bying this 1004 burner I saw all kind of bad comments about it but I said to myself : let’s give it a chance…
It can’t be that bad and I read some good reviews in magazines.

But now, I must admit I was wrong…:frowning:

Thanks anyway for your support, I will contact emprex after sales now…

There is only one media that works perfect with this drive (i have the same )
Taiyo Yuden
Believe me i learnt it the hard way

Thanks all,
I have new statements to share that may help see the light !

Reading this forum, it seems I am not the only one to have some problem with bad quality burn at the end of the DVD.

After many tests and DVD sent to trash, here is my conclusion and statement:

  • The problem only occurs in this case : long time movies with high compression level. (Tipically movies that last more than 120 minutes). I use DVDshrink that apply compression to reduce movie size to 4.7GB. A long time movie (more than 2 hours)usually need 30 to 35% compression ratio to fit in a DVD-R.

-There is absolutely no problem if the compression level is low. (even if the DVD is full)

-This problem occurs for ritekG04 but NOT for TDK DVD-RW.

So, now I am pretty sure that the issue doesn’t come from a flaw of my burner but rather from a firmware/media compatibility issue.

I am pretty sure now that anyone who want to burn a long movie using high compression and ritekG04 will meet the same errors.
I can’t believe BTC is not aware of it since ritekG04 is a best seller and recommended on their web site.

Waiting for your opinions and hopefully solutions to save my ritek spindel from trash :wink:

I read on this forum that people sometimes recomend to use firmware 043 for RITEKG04 media.

  • Is it possible that 048 fail where 043 not ? I mean, is regression possible ?

If YES, then can you advise me about which FW to install and where I can find it ?

Thanks in advance …

I can’t believe this drive only works perfectly with one media (Previously mentioned Taiyo Yuden that are one of the most expensive media we can find !)

Look here, and take your pick.

Regards, Martin A

Thanks Centurio,

I already had this link, this is not really the point…
The point is rather to know if people have troubles with 048 that were solved by downgrading to 043…

I read so many post about dead drives after FW update that I would like to be sure that it is worthwhile before doing it.

That’s why I asked people experience in this field and if it makes sens to downgrade my FW.

Thanks anyway for your help :slight_smile:

With MTKFLASH under DOS (don’t know about the Windows version) you should be able to flash from any firmware version to any other firmware version.

Even if you should manage to kill your drive while flashing, I’m pretty sure you could revive it - unless it is a hardware fault, of course. A number of viable approaches were posted in this forum.

Regards, Martin A

I forgot:

Even though Marco BTC says there’s no going back to a previous fw version - this is BTC’s proclaimed viewpoint and may be true for them (and rightly so).

However, this view is not something which must necessarily be adopted by the user. All right, if I go back to an older fw, I should know about the risks I’m running by taking this step, i. e. no manufacturer support (or whatever else comes to mind). If I don’t know reasonably well what I’m doing, I have no business in messing around with firmwares anyway.

I’ll always use the fw which meets my particular needs. If I should happen to have a trunkful of disks which can be burned, with acceptable results, only using an otherwise competely outdated fw, I’d be a fool to throw them away just because I’m running the latest poop and don’t want to go back. I’d sure as h*ll get out the old guns again.

Regards, Martin A

Thanks a lot Centurio,

so I guess you agree that regression in FW is possible and it’s worthwhile to try an older FW…?

If this is true, I find it incredible that BTC can find the correct settings for a FW version and loose them after !!!??

BTW, as I am not very confortable with RPC1 FW, do you know where I can find the official 043 window flashing tool ?

Thanks again and regards.

@cyclope

If you send me a PM with your email address I can give you the official BTC flash package with the 0043 fw (flash proggy included).

Regards, Martin A

Finally I solved my problem !!!:slight_smile:

All bad performances with ritekG04 seemed to be due to a conflict between Nero and EasyCD creator (DirectCD) that were both installed on my PC.
This is abslutely crasy but true !

Below, you will find the new KProbe’s graph just after EasyCD Creator removal.

What is really crazy is that the problem really arise with G04 and not with TDK media (TY01)

At the end of the day, it was not a FW issue nor a media issue.

If you ask why I had those 2 burning software on my machine…
Nero and ECDC are both OEM softwares so I need both of them to be able to burn on 2 different devices I have. (Emprex + other)

To finish, conflict between Nero and ECDC seems to be known but I would never imagine that consequences could be poor quality on some specific media…

So much time and energy lost to discover this…humm…

Thanks to all of you anyway !


> All bad performances with ritekG04 seemed to be due to a
> conflict between Nero and EasyCD creator (DirectCD) that
> were both installed on my PC. This is abslutely crasy but true !

That old friend again! Not crazy at all my friend. This conflict happens a lot. Even after people have removed Roxio Easy CD Creator by the Add/Remove Programs option in Control Panel. There are some registry entries which are not removed. And other stuff I think.

> If you ask why I had those 2 burning software on my machine…
> Nero and ECDC are both OEM softwares so I need both of them
> to be able to burn on 2 different devices I have. (Emprex +
> other)

It is crazy this OEM software limitation.

I have a story about that.

When I bought my 1004 DVD writer I removed my old CD-ROM drive & installed the BTC as secondary slave, retaining my LiteOn 48x12x48 CD rewriter as secondary master.

I found that my existing version of Nero (early version 5) gave bad results with the BTC so i installed the Nero on the disc in the BTC package. It would burn to the BTC but refuse the Liteon. So I had to turn to Edonkey to help me with my little problem. Which took 5 minutes. (I shall not say any more.)

If you have 2 burners installed, OEM bundled burning software can be a big pain in the butt.