Ripped DVD to MPEG for MCE extender?

Is it possible to use DVDFab to rip the DVD to one big AVI or DiVX file so my xbox or other extender to play it? Today what I have to do is rippped it, use VOB2MPG to make it one file. I like to have this done in one shot. I know DVDshrink can do this but it won’t work on some of the new movie. Or if any other format that would work on MCE extender without loosing much quality. Any suggestion would really be appreciated. TIA.

DVDFab’s Mobile option has a function called VOB Passthrough that will do this to the VOB files if the target drive is NTFS–all you need to do is change the file suffix to MPG. It will also make AVIs, MP4s etc. with AAC, MP3 or pass through the AC-3 (or other) audio from the original and sync it to the MPEG-4 video. The VOB Passthrough processing is very fast. If you are picky about the video quality (like me), use the VOB Passthrough. You can make an MPEG-4 conversion that looks pretty good with h264 but it’s not quite as good as the original to me, and processing takes much longer. Your mileage may vary.

[QUOTE=sangleweb;2224148]Is it possible to use DVDFab to rip the DVD to one big AVI or DiVX file so my xbox or other extender to play it? Today what I have to do is rippped it, use VOB2MPG to make it one file. I like to have this done in one shot. I know DVDshrink can do this but it won’t work on some of the new movie. Or if any other format that would work on MCE extender without loosing much quality. Any suggestion would really be appreciated. TIA.[/QUOTE]To answer your question in one word yes.

Use the mobile option in DVDFab generic (xbox360 option is slow and makes a wmv file), uncheck subpicture (unless youwant subtitles) then click next.

Click conversion settings, on the device line in the second drop down choose generic.avi.xvid.audiocopy.

Encoding method choose High quality encoding (2-pass).

Set fixed Bitrate to 3072.

Click Ok

Click Start

This will give you near original quality.

Let us know how it goes and good luck.

Thanks for the info, I saw all those options but unsure what they are.

The VOB Passthrough option is located in DVD to Mobile->Generic. It is the bottom profile selection. There are no settings to change other than the filename. My xbox360 device in DVDFab has two profiles–the wmv/wma one which does indeed run very slowly and an AVI xvid+MP3 one that runs much faster. VOB Passthrough will preserve the original audio but will not embed subtitles into the video the way the other mobile modes will.

I trid the VOB pass-thru & it didn’t work for me. VMC wouldn’t play it. After that I tried to double click the file to see if media player would open it & nothing, didn’t even recognize the file type. I went back & renamed the file suffix to MPG & still nothing. Any suggestions? I tried a couple of things under Generic & they worked fine. I just wish the VOB pass-thru would work for me as it is alot faster.

All of the test “plays” were done on the computer & not on my DSA-2100 media extender. I know if my computer won’t play it, my media extender won’t either.

Just tried a quick one and it plays fine with VOB or MPG suffix on VLC media player, WinDVD5, WinDVD9 and WMP10. The deinterlacing was not right on WinDVD9 or WMP10. Not sure what you are seeing unless it is content related.

[QUOTE=signals;2225711]Just tried a quick one and it plays fine with VOB or MPG suffix on VLC media player, WinDVD5, WinDVD9 and WMP10. The deinterlacing was not right on WinDVD9 or WMP10. Not sure what you are seeing unless it is content related.[/QUOTE]I doubt he is going to be able to use a VOB file to play on his extender. VLC is a great player but as a media server it is not GUI as far as I can tell.

Try renaming the the VOB to MPEG it worked for me.

[QUOTE=Monkeycowboy;2224159]To answer your question in one word yes.

Use the mobile option in DVDFab generic (xbox360 option is slow and makes a wmv file), uncheck subpicture (unless youwant subtitles) then click next.

Click conversion settings, on the device line in the second drop down choose generic.avi.xvid.audiocopy.

Encoding method choose High quality encoding (2-pass).

Set fixed Bitrate to 3072.

Click Ok

Click Start

This will give you near original quality.

Let us know how it goes and good luck.[/QUOTE]

I’ve been doing this with great success. The only thing I would add is that they might need to add the AC3filter codec to Windows Media Player.

I usually set my bitrate to 2048, for no other reason than it’s a nice round number. How did you arrive at 3072?

My goal has been a single file with as close to DVD quality as possible that plays on the Xbox360 video library player (don’t care about Windows Media Center).

[QUOTE=Monkeycowboy;2225861]I doubt he is going to be able to use a VOB file to play on his extender. VLC is a great player but as a media server it is not GUI as far as I can tell.

Try renaming the the VOB to MPEG it worked for me.[/QUOTE]

I could not get a VOB file to play on my Xbox360 even after renaming it to .mpeg. It’s not supported.

[quote=Monkeycowboy;2225861]
Try renaming the the VOB to MPEG it worked for me.[/quote]

OK I’m a dumb a$$. I tried to change the file extension in Windows Explorer like I’ve done in years past but this time for some reason it only changed the last part of the name. The file extension is still listed as .vob. Take me back to primary school please & explain how to change the file extension from .vob to .mpeg…or is it supposed to be .mpg?

The original file name is [(BODY_OF_LIES.Title1.DVDRip).VOB] For some reason explorer won’t give me access to the file extension in the rename command.

Change to BODY_OF_LIES.mpg

Did it as per my previous post…again

This is what I’m ending up with…it’s still listed as a .vob file The rename command in windows explorer isn’t giving me access to the file extension. I’m running Vista if that helps.


I’m using Vista and I just right clicked and renamed the file. You may need to go to the Organize button at the top of the explorer window and go to Folder and Search Options, View tab and under advanced settings, uncheck Hide extensions for known file types.

Looks right to me iceman61. All you are changing is the file extension, it will still be a vob file but the player software that needs an mpg extension will play it.

Thanks for the help guys.

Jeff, you hit the nail on the head. Thanks! It works like a charm now & it is playing in VMC. The other way, I was only changing the file name & not the extension. Sometimes it’s the simple things that cause you to stumble.:doh:

I’m having a few other minor problems but I’ll post those in a new thread.