Ripped BLuray playback in Spanish

Hello all, I can’t shake this problem to save my life! Every time I rip to hard drive using any dvd hd. the .m2ts files are in small chunks which play in versions 7.3 ultra and 8 ultra Power DVD. Only in spanish. The LG GGC H20L region is set to Region 1, and the Settings in Anydvd are Region A. Any DVD ver I even tried ver and got same result. I’m looking for English here. Anybody having similar issues? Playback res. 1080p. I’ve uninstalled LG and let it reinstall. It has ver 1.03 firmware. I have had great success with this before in a machine that had an ATI HD2900XT So far with this machine, it’s been a recurring nightmare. any help would be much appreciated.:sad:

XP Pro SP3
EVGA 780i
Corsair Dominator Two 2gig
E8400 CPU
DVI to HDMI adapter
LG GCC H20L w/firmware update

Well, I don’t have PowerDVD or anything. But when this happens to me it’s because my playback software is selecting the first audio track it understands and it doesn’t understand DTS-HD or Dolby TrueHD. A foreign language track is often the first Dolby Digital (AC3) 5.1 track on the disc. Sometimes it’s the ripper or reencoder/remuxer selecting that track, sometimes it’s the playback software.

It sure looks like any dvd is only picking the spanish tracks when it does its thing. It seems to be skipping the english tracks selected in any dvd settings. One thing I noticed in the any dvd information box was "Disc Region not recognized"Ive tried about everything and the same tracks keep coming up. I’m about to see blood shooting out of my eyes!