Ridata DVD+RW discs

vbimport

#1

Bought a spindle of 25 DVD+RW ridata discs before christmas and I cannot burn them on three different DVD drives.

Each one says:

Error writing to disc
Unable to perform disc at once
Error formatting disc

When I try to simply perform a format, it ends with a box popping up in Nero that simply says ‘error’

I have tried to different versions of Nero 7.x both with the same results.

I have tried these discs in the following drives:

Benq 1610
Nec 3540
Optiarc AD-7170A

I can provide firmware for each of the drives, but do you really think its a firmware issues on three different drives?

Any thoughts?


#2

My first idea would be a media problem - the Ridata discs, putting it kindly, aren’t…good. The fact that 3 different burners won’t touch it points to that also.

I’d try some Verbatim, they should burn nicely. :wink:


#3

I’m thinking that your discs may be 8x DVD+RW with the media code RITEK 008, which are not widely supported. I don’t remember exactly if they are supported in the drives you mention.

You can check the media code on the Disc Info tab in Nero CD<DUMMYTAG>-DVD Speed.


#4

Hmm, never had any problem with the Ritek 008 discs I have. I know my 3540 did a good job with them with the more recent firmwares at least, so maybe update the firmware on it and see what happens.