Revert PX-B940SA to original firmware

Years ago I flashed my PX-B940SA to Pioneer BDR-205. After lot of use, I put it in a drawer and forgot it.

Now I want to use it again but when connected to SATA, it powers on, tray works but can’t recognize disc.

As a last resort I would like to revert original firmware. Is there any procedure?

Of course using Plextor flashing is not feasible as it doesn’t recognize the drive as Plextor one.


Hi tormento, I ran into a similar problem with a bluray drive a couple of years ago. I finally had to back up my system and do a clean install of windows. Once I did that, the stubborn hardware was finally recognized and worked normally. Keep in mind that the drive just signals to the OS that a volume is mounted, it is up to the OS to recognize it. One suggestion for testing. Download and create a bootable USB thumbdrive with LinuxMint. This should let you boot the PC off of Linux and see if the drive is recognized. If it isn’t then it is possible that the drive or SATA controller are kaput.

I doubt a firmware change will help, btw does the drive fail to recognize any disc (CD, DVD and BD) or is the OS unable to show the contents?
Another user had a problem where the drive didn’t detect any disc anymore, and it turned out a cable got disconnected inside of the drive, so it could be worth a look.

The drive fails to recognize disks, of any type. No spinning, whatsoever.

I tried to replace cables and used linux live CD, same behaviour.

I’d like to reflash firmware, as last resort, but don’t know how.