Restoring corrupted cd-rom data?

vbimport

#1

hi all !

i got a 3 year old data cd-rom iso9660. but all of the cd-rom players i tried didn’t read (didn’t display the folders/name of the cd) the cd any more. some checking utilities say that there’s a corrupt “primary volume descriptor”.
is there a way to restore the data somehow?
i tried cdr-diagnostics, cddr11, cd data rescue … but the programs only recognize the session of the cd, but are not able to display any folders or files on the cd.

thx in advance

my_kill


#2

try this

http://www.cdfreaks.com/news2.php3?ID=5031

maybe wont work but worth a go,

regards,
yates.


#3

You can try to extract the data with isobuster


#4

thankx yates, thankx crowley,

but :

unstoppable copier don’t work

even

isobuster don’t work

because of the missing “primary volume descriptor”.

any further clues

thx again

my_kill


#5

If you can’t read it with the programs you’ve tried, it’s unrecoverable.


#6

Please describe detailed what you’ve tried with ISOBUSTER.

Probe to ectract ranges of sectors, save and convert the CD segments in 2048 data bytes/sector format and copy-paste with hexeditor the dataparts between the zeroes.

And next check out the right file-extensions, maybe you know what kind of stuff is on the disk (pix, movies, programs).

:eek:


#7

Originally posted by Inertia
If you can’t read it with the programs you’ve tried, it’s unrecoverable.

I agree in a large measure, but if you have important data that you must recuperate you may want to look into data recovery specialists. There is a company out there that used to offer these services for a fee. Don’t know if they are still around, I don’t have the link anymore.

I have used CD-R Diagnostic with succesc once, glad I had it. But it took 2 hours to read the damaged disk. Just wanted to let you know in case you didn’t give it proper time to process the whole disk. Oh, and set the CD-ROm at the lowest speed you can, makes it easier to read, instead of making it hunt and hunt.


#8

Try Badcopy, this one helped me out quite some times with restoring floppy discs. It has a CDROM-restore feature as well…


#9

I had a problem similar to you. a Kodak gold from 1995 or so that looked as if there were small water drops between the protective layer and the dye or in the dye itself (It had always been stored in cool, dark, dry place). A year ago, none of my drives could read the CD at all (That included very fine drives like Teac, Plextor and Philips (all burners)). Then I got my 1st Liteon Burner (24102b) and it reads it!! It cannot read all the files, obviously those with the waterlike marks are gone forever, but using CDR-Diagnostic i could rescue a fair share of about 80% of the data.
I recently got an Artec 16x DVD and it seems to read a few parts of the CD too, not as much as the litey though.


#10

I had a similar problem with a Kodak CD-R Ultima 80, made in 08/00, burned ~late 01, early 02 maybe.

Loaded the CD with anime on it, just checking it out after such a while. It worked, but I did notice the CD name was marked as invalid or corrupted or something. I thought it would be fine, every file on it worked fine, but now when i pop it in, it can’t reconize ANYTHING. Boy, Kodak musta f’ed really bad or something. Never had this happen to me before! (Except for severely scratched CDs (it wasn’t me :stuck_out_tongue: )