Resolved: Benq 1640 problem with firmwareupdate

vbimport

#1

Hi, this is just for information.

In the past I’ve had a problem updating my 1640 to a newer firmware.
All the programs work well with the writer only the firmware-update-program can’t see the writer (the 1640 didn’t appear in the listbox).
After making a fresh WinXP installation the writer is selectable in the firmware-program.
Then I installed the drivers step by step and tested the firmware-program.
After installing the VIA IDE Accelerator the writer is gone in the firmware-program. Going back to the MS IDE drivers solved that issue.

I’ve tried the same on my old XP installation and the MS drivers are shown in the device-manager too but the firmware-program can not see the 1640.
I seems that the VIA driver are very obstinate.
Only a fresh WinXP solved the problem.

cu
TopPlayer


#2

Thanks for the info.

I think some people will appreciatte this info. :iagree:


#3

Coming from NEC’s world, I can say that this is very old news. See the FAQ :
http://club.cdfreaks.com/showthread.php?t=120934#fw-drivers

Q: Do I need any special drivers before I backup or flash firmware?
A: It’s been well proven that Microsoft’s default IDE drivers work best. Not only for flashing and backing up firmware but for general good and smooth operation of DVD±RW drives and the software used for burning and scanning.

Maybe something to add to the general DVD FAQ or BenQ FAQ.


#4

@ItalianJob
yes that’s true.

But I’ve found the real reason what’s the problem with the firmwareupdates.
Not the VIA-Accelator is the reason (there are problems using it with CDSpeed).
The Benq software-programmers doesn’t seem to know that it’s possible to assigne the drive-letter ‘Z’ to the 1640. With ‘Y’ no problem. With ‘Z’ neither the Benq tools nor the firmware-update-programs can find the drive.

Hope this helps.
Perhaps someone should tell this a Benq coder.

cu
TopPlayer