Republic: The Revolution (Securom 4.84.84.0052) problems

Is anybody having trouble backing up their original of this one ? I’ve tried Alcohol (albeit v1.4.2) and Blindwrite (v4.5.2.72) without sucess, with a Liteon based burner (Uranus 52x24x52x).
Securom hasn’t posed a problem up till now :frowning:
However, from my limited testing, the blindwrite image, mounted with DT passes the cd check.

I’ve also tried running from a dvd drive with the same results. Looks like Securom is getting perfected (surprise, surprise)

profess,

I used blindwrite not on that game but same protection to back up my games … if you want you can message me on msn to help ya

msn messenger

just IM me or message me

giovanni40220@msn.com

i would like to know the burner model and what error your getting and some more info then iti s not doing right hehe

the burner model is CDR-6S52 with firmware 6SG1 (clone of the LTR - 52246S).
I have just tried with blindwrite 4.5.7.92 with no change in the results.
Also, the Alcohol emulation failed (unlike DT, v3.33)

hmmmmmmmmmm … okay your burner if i am correct can do the latest securom …

what does your verify screen look like ? cause i wonder if image is good at all at first ?

also when your in blindwread you just have autoplay checked …and then burn at what speed ? max ? dao pw ?

also blindread do you extra subcodes and dont …most of the time with higher protection you dont have too … i do just incase … also nibble and 1x to max ? how does the bwafile look ?

well, the image must be pretty good 'cos the game ran with DT and RMPS emulation.
blindwrite autoplay was used, burned at 12x onto cdrw, dao pw.
I’ll update the firmware and try again…

Have you (or anyone else) actually successfully backed up Republic then??

well image cant be too good if you have to use rmps emulation to get it going …

I dont have that game but I have several games with that copy protection that i have backuped …

well I see there is till no verify screen … do you have log of what it did ? and also where are you getting your bwa ? is it smooth ? well just message me via msn messenger …

securom is not hard if you hav ethe right bwa and right settings in blindwrite …specially if you have done all of them before …what isthe error your getting is it in the install or playing the game

ok, let me put it this way, I think that this version of Securom is different from it’s predecessors. There is a significant cd check perfomed (disc one, check only done when playing).
You’ll have to get hold of an original t o see exactly what I mean.

The very latest versions of securom have new blacklistings of alcohol’s virtual drive and, possibly, RMPS emulation. This is expected to be overcome with the next alcohol release.

In the meantime, twinpeak copies are still reported to work as are plex premium blindwrite copies.

phil … .

your the man …I jsut told him the same exact thing in message …he message me on msn …lol …just was good to see you said same thing as me …cause not sure if he really believed me or not …plus gave him the bwa i use to make my back up … hehhe

i told him to turn off virtual drives and take off clone cause of blacklisting hehhee

just glad to see that come up at right time …

thanks again phil …

he is going to see if he can get it working now …

success!!!
updated the firmware to 6SG5, and burned again with blindwrite. Works with Alcohol virtual drive present as well.

Phew, I was getting worried for a moment…:bigsmile:

i’ll try with Alcohol again in mo…

woohoo good job professor

your welcome …glad i could have helped … remember protection is actually a four letter word lmao hehhe

Alcohol burn ok as well now.
cheers giovanni

what about a nice plex premium to make a 1:1 backup of that damned securom 4.8x?
I have one and works nice:bigsmile:

arrgghhh…I tried to run the backup just now and I’m back to the same problem! Anyone else had this kind of problems???

you made backup with autoplay correct ? blindwrite needs to be installed or autoplay client setup

lite 32x12x40
bwa build 4.5.7 latest (read 2x) = success

I’m about to get to work on this one now but I doubt I’ll have much luck. Got another SecuROM new 4.84.84.x game that I have tried to burn with everything and to no avail. Image works fine though when loaded in DT. :confused:

what type of burner 420 ? what kind of cd roms do u have ?

i’m not alone then…phew, but still :frowning:

giovanni42104-

Using an LG 8520B with the latest firmware to rip and burn m8. It works great for up to SD 2.8 and SecuROM 4.84.81.x but I have had no luck on SD 2.9 and SecuROM 4.84.84.x I’d like to think it’s as simple as a blacklist on one of the apps I’m using but I can run the images off Daemon Tools v3.33 and the games work fine … when burned to CD though, no luck. :frowning:

The games I’m stuck on atm are:

  • Republic: The Revolution - SecuROM 4.84.84.x
  • The Temple of Elemental Evil - SecuROM 4.84.84.x
  • Devastation - SafeDisc 2.9

and there’s one other SD 2.9 title that I can’t recall the title of.

btw … Republic I can’t even run off the original so I’m gonna have to work with ToEE and if I get a working method for that, will simply use the same for Republic.