Replacing a laptop DVD drive issue

vbimport

#1

Hello everyone,

I have a Packard Bell EASYNOTE E4710 laptop (bought in 2005). (Please do not send me links to their customer service).

I urgently need to replace the defective NEC ND-6500A (made in 2004) slimline internal drive so I bought a TEAC DW-224E-C59, HW/FW ver. 02/A.AC. The BIOS does not recognize the new drive, probably because the original NEC drive is configured as “master” and the new TEAC drive as “slave”.

Question 1: Can I replace the old drive with a new one without making any changes, in other words, which modern slimline DVD drive is compatible with NEC ND-6500A?

Question 2: Can I change the TEAC drive’s configuration to “master” by soldering pin 45 to pin 47 of the IDE interface as shown [here](http://www.packardbellweb.co.uk/hdd/installguide/50-pin ATAPI interface connector for laptop and slimeline cd.htm#CSEL_to_cable_select_one_)

Question 3: Is it possible to change the TEAC drive’s configuration to “master” by flashing the drive’s firmware (an easier option) and how to do it?

Question 4: Is there a way to check the mode (“master” or “slave”) of a slimdrive DVD when searching for a replacement?

Please help!

academica


#2

I don’t think you have a Master-Slave issue. IDE cables that have two connectors AND two devices on those two connectors will use the Master-Slave settings. But notebook IDE cables are going to be single-connector-only - and very short - an inch or two - because they also have Power Cables embedded. No “Master or Slave” should be useful.

I think this is a BIOS issue… or a bad replacement device. Ugh.

I’d go back thru the BIOS and look for any IDE-Storage ENABLE-DISABLE options there are. And maybe there’s an Auto-Detect feature?

For device testing, you might take the replacement drive to a friendly used-computer shop and see if they have a notebook with an IDE DVD to test it on.

Oh… maybe another way… I think some of those IDE-SATA USB plug-in converters have the mini-IDE connector on them. That might tell you if it’s working. (Here again, a friendly shop might have one of those around anyway, and might be agreeable to let you test it. If you’re near a college campus, there should be some used-computer shops near those.)

Sorry… no other suggestions, though.


#3

laptop IDE drives still use master or slave despite no cabling, or very short ones… even if they are on discrete channels

toshibas use slave for the CD/DVD drives, and will fail to respond to the cable select setting most CD drives use (most brands of laptops are fine with cable select) as well as the master setting

the best thing to do before diving in to mod your drive is to get a slim line to regular IDE cable adapter and plugging the drive into your desktop to see if it shows up… you will also be able to find out which setting it is on
some brands allows you to change the setting by software, but I don’t know anything about the teac


#4

I pulled out two old Dells and one had a single IDE ‘address’ in the BIOS so it’s HDD and CD were indeed Master/Slave on that single channel, but no pins were offered - that means a ROM setting, then. On the slightly newer Dell, it had 2 IDE channels in BIOS, and I swapped DVD and CD drives interchangeably and they were acknowledged in each of the two computers.

So the DVD had to be set as Cable Select or Slave for the older Dell to acknowledge it on the same channel that its orig CD drive used.

And the older CD inserted into the newer Dell was also acknowledged properly, so it’s settings weren’t in conflict, but since it used a separate IDE channel, I didn’t expect that.

Were all slim-line Optic Drives set as Slaves or Cable-Selects, perhaps? Well, if they were, then Acad’s issue wouldn’t be an issue-! So apparently not all were ‘set’ with Slave settings. Spartacus will be glad to know.

But none of this solves the issue, but at least Kouryu’s bright light brought out this. It makes me believe this was a trick by the name-brands to ensure future replacement-part sales. Grrr - anything to make it difficult on consumers-!


#5

I don’t have any dells old enough to use single IDE channels
but I had a dell OEM ND-6500A before, and now I have 2 ND-6650As now… both models of these drives show up as “master”… not sure if they’re internally set as cable select or master though
these are real NEC drives, not Optiarcs, so they’re a little different :wink:

the version number of the firmware on NEC drives is a clue whether it is a master or slave IIRC… I’m no expert, Liggy and Dee are :wink: From what I could tell, 1.xx is “master” and 2.xx is “slave”… but don’t take my word for it… I’m really not sure!

no telling how teac does it, if at all


#6

1xx and 2xx… interesting, I’d have never noticed. I suppose in the days of an 8Mb video-chipset (as my older Dell has, and that runs DVDs just fine), then skimping on IDE-Port Memory Overhead might be their good choice. I’m still not sure how much more memory-overhead a 2-IDE-Port assignment would consume vs. a Master-Slave memory-requirement on each signal being transmitted to and fro the devices.

And perhaps the IDE-chipsets were so huge, too, that having 2 installed on the MB wasn’t physically possible, so they used only one and then built HDDs and CD-DVDs with some built-in setting.

I had trouble with Cable-Select settings for several early years on Desktops and, still, to this day, will pin-set a Master or Slave when I run across those.

Thanks for these notes. I’d have never thought this to be true, otherwise. “Surely, those designers wouldn’t be THIS stupid-!”


#7

From what I’ve read on the net so far it seems that Kouryu is on the right track. Firstly, it’s true that NEC ODDs are set to “master” but others are fixed to “slave” and this could be a reason for incompatibility. ChristineBCW is probably also right saying [I]‘It makes me believe this was a trick by the name-brands to ensure future replacement-part sales.[/I]’ The fact that this information is not mentioned in any hardware specification of any ODD and there is no easy way to find out the factory setting of a drive speaks for itself. I guess there must be a kind of a non-disclosure trade agreement among producers about this issue, which sounds ominous.
But my issue is still unresolved, so if anyone knows anything about this secret, please share it.


#8

Acad, very sorry to hear that the solution remains illusive.

I can’t imagine trying to diagnose this thru text, though, and that’s why I’m hoping you’re near some college or town with a used-computer shop who might have someone who might see something that’s been overlooked or not considered.


#9

Hello again,

I’m glad to report that I have solved the problem with my optical drive’s compatibility. You don’t need to flash firmware or bootcode, you don’t need adapters, converters, nor a desktop. All problems are because of the factory setting to “master” or “slave” and the lack of an easy way to change the mode. So one really needs to shortcut pins 45 to 47 on the 50-pin drive’s IDE interface as described here

I changed the mode to 3 optical drives and this solution works flawlessly.

The problem is probably a technical issue, as described here. Quote: “[I]But technically it’s not the drives fault.Mainly Toshiba and IBM laptops have this problem while other laptop vendors work perfectly fine with Master Drive settings[/I].” Obviously newer ODDs are set as “slave”, but NEC (and some other brands) need the ODD to be “master”, as described here
And finally: if the BIOS cannot find your optical drive (but Windows can use it) all you need is to change the mode from “master” to “slave” or vice versa by a soldering iron. Connect pins 45 and 47 to make it “master”. Separate 45 from 47 to make it “slave”. Good luck!