Replacement Burner...suddenly problems

Recently wore the burner out in the desktop computer, so replaced it with a Pioneer DVR-710. Removed the old burner (Toshiba-Samsung H552), Installed the new burner and left the factory jumper setting at master…ran DVD Fabxpress (no, I haven’t switched over to Gold), and went through the normal copy process on several different DVDs…appeared to have no problems and never received any error messages. However, after attempting to play the burned DVD on home DVD player as well as computer, it’s obviously not working. The DVD player says “Can Not Read Disk” while the computer says “Windows Can Not Read From Disk”. After figuring out that the jumper on the new burner needs to be set on CS (Cable Select), I performed a computer restore back a few days, and then went at it again. Still no success. Thought it might be a bad burner, but just now tried the “stock” burning software and it worked ok…so now all theories are exhausted. The disc’s appearance looks “normal” after they’ve burned. The process goes down just like it did prior to the switch…the only difference being is the discs don’t play. Fengtao, Your help is appreciated!