Remote Desktop/Assistance

Hey all,

I’ve recently just acquired a “new” computer (P3 933 hehe), and i thought it would be good to set it up as a storage computer in my spare bedroom. So I’ve plugged it into the network, along with two other computers.

I had the idea that i could run this “new” computer without a keyboard/mouse/screen using remote assistance or remote desktop.

What I want to be able do is: Turn both computers on and let them boot. When they are ready, I want to be able to control the computer in the spare bedroom, from my own computer in my own bedroom. But I need to be able to send a remote invitation from the computer in my bedroom, to the computer in the spare bedrrom and have it accepted without having to touch the computer in the spare bedroom. Is this possible?

Thanks all,
Sian

Yes it’s very possible.

Before you start you can create the same username on both PCs (and same password). Also note the computer name of the remote PC (check the name from Control Panel > System > Computer Name). For example the name of your remote computer (in the spare bedroom) is SPAREBED.

  1. Make sure the remote computer has Remote Desktop enabled. Control Panel > System > Remote Tab > Tick on “Allow users to connect remotely to this computer”. Click on Select Remote Users. Add username that allow to connect remotely.

  2. On the client computer, click Remote Desktop (Start > All Programs > Accessories > Communications). Type SPAREBED and click Connect.

  3. On the credentials window, type username and password. This username and password must be registered in the remote computer’s Windows.

You may need to enable firewall on both PC when it pops up.

Cheers, ill try that soon. But does it matter that my computer is using windows vista and the sparebedroom computer has windows XP?

Should be no problem. :slight_smile:

zevia,

Thanks for the help. I do have another question though.

The connection works fine, I can control the computer with no problems. But, now if I turn on the sparebedroom computer, it will start up and go to the account selection screen, where I will have to enter my password. This is difficult as I am aiming for the computer to have no keyboard/screen/mouse when i install it into the sparebedroom.

Is there a way to use remote desktop without a password, or is there a way to get around this startup screen, something like “use this account automatically on startup”?

Cheers
Sian

Yes you can automatically login using TweakUI (part of MS PowerToys), or with built-in commands:

  1. Start > Run > type “control userpasswords2”, press OK
  2. Select the User Name you want to auto login.
  3. Un-tick “User must enter a user name and password to use this computer.”
  4. Click OK and enter Passwords.
  5. Restart the PC to test.

:slight_smile:

Wow, thank you very very much!

You’re a god! :bow:

  1. The spare PC must be running the WinXP professional. The Home version requires an invitation.
  2. The spare PC must have a password on the account, otherwise you cannot login remotely. Use tweakui (as above) to have automatic login with a password.

Yeh thanks, I fixed it. Works perfectly now, just as I wanted.

THANKS!

Have you ever tried using radmin? It’s a really handy program and it works way better than remote assistance. Personally I use Remote Administrator 2.2 and I’m pretty happy with it :slight_smile:

Radmin can also have the person logged in, when the admin is logged in, and the user can see the process for doing something.

If you want to NOT have a password on the remote machine, it is possible (in XP Pro anyway).

Click Start>Programs>Administrative Tools>Local Security Policy. Select Local Policies then Security Options. About the 3rd item in the list is called ‘Accounts: Limit local account use of blank passwords to console logon only’. Disable this and you do not need a password to use Remote Desktop.

This works a treat for me when I need to ‘be in front of’ one of many PCs at my work while I am at home.

Cheers Guys,

Radmin seems a good program but i don’t really want to pay for anything. :o

Btw, I solved the password problem with a solution mentioned above.

Cheers
Sian