Refresh problem in Windows XP SP2

Hello!

I have a problem with my win XP SP2.
When I eject some CD or DVD from my CD-RW/DVD-RW unit my operating system is not refreshing. I mean if I am in Total Commander and I see the content of my CD-DVD before ejecting this, after ejecting I still see the content, but on other pcs I’ve seen that imediatelly after eject SO is refreshing and not showing that old content.
And after this is happening I can insert another disc, with another content but … my Total Commander thinks that I have inserted the old disc … and there are problems of finding that old info on new inserted CD-DVD.

I can recover to a normal state only after restarting Total Commander. The same situation is in Windows Explorer. Sometimes is blocking my all OS and I can only restart my PC from button.

Do you know some key in registry to modify or anything else just not to see this happening again. I’m sick of it …

Is autorun turned on? If not try this:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"="1"

Check out what Microsoft has to say about it:
http://support.microsoft.com/default.aspx?scid=kb;en-us;314939&Product=winxp

And if you still can’t fix it try this utility:
Autoplay Repair Wizard

Could be Auto-Insert Notification needs setting and Media Change Notification needs disabling.

These are registry settings but I’ve no idea where so I use ImgBurn to do it. Great burning app btw so well worth having.

Solved this problem for me.

Thanks for your reply [B]TimC[/B] and [B]espresoo[/B].

Actually I disabled the Autorun thing … because I don’t like it. But
on systems with Autorun disabled I did see the refreshing …
I’ll try to re-enable the Autorun to see what’s happening …

Hello :slight_smile:

I did it !
I did what TimC and espresoo said and now it’s OK
My XP is finally refreshing after ejecting the disc.

I also installed ImgBurn. I’ve heard that ImgBurn is better on burning to DL.
Is it really true?

These are the settings I’ve done. In ImgBurn Settings, Regedit and Group Policy.




  1. Enable Auto Insert Notification for CD Drives
    Some programs will disable this default setting to play inserted CDs automatically! Roxio applications do this; for example! To re-enable this functionality >>>
    � Navigate to the following Registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
    � Double-click Autorun
    � Make sure the value is set to “1” under Value Data.
    � Navigate to the following registry key:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer.
    � Double-click "NoDriveTypeAutoRun"
    � Make sure the value was set to “91” under Value Data.
    � Close the registry editor
    � Restart your computer.
    You should now be able to pop in a CD, and WinXP should pop up the autoplay menu and attempt to autorun the CD.
  2. Disable AutoRun for the CD-ROM
    One of the easiest ways for a hacker with physical access to a company’s PC’s to distribute malicious code is via the CD-ROM. By creating a custom CD with a payload set to launch from the AutoRun feature in any machine, a hacker can affect any number of unlocked systems without ever leaving a fingerprint or touching a keyboard. Or he/she can simply leave a few of these lying around the office marked “MP3’s”, or “Payroll Data” and wait for an unsuspecting user to simply pick it up and insert it into their machine. You can disable this function in WinXP Professional by
    � Clicking Start > Run > and type GPEDIT.MSC
    � Go to Computer Configuration > Administrative Templates > System > Locate the entry for Turn AutoPlay off

Please let us know what finally cures your problem by posting back.
Good Luck and as you can see: we are all wishing you the best of success on this glitch! :rolleyes:

You might want to check the date of the posting was back in 2007 and OP hasn’t back…

this is the third one another from 2004