Recovery from a bad flash? Warning for Sony DRU-810A-R!

I just purchased a DRU-810A and attemped to flash it with windwflash and the BLSB.CVT in order to use DW1640 firmware. Flash seemed to go good and I received the message to reboot. Computer locked up when trying to restart so I was forced to hit reset. On reboot computer would no longer sees the drive and it appears dead. Tray will not open or no flashing lights. Is there any way to recover it?

was there any disc in the drive when you flashed it? try reflashing it in SAFE MODE.

No disk in the drive when flashed. I tried safe mode, but the drive is very dead. No indication of power and tray does not open. The drive has DRU-810A-R and was built in April 2006. Could it have been something other than a DW1640 maybe? It looks just like my other real DW1640, but so does my DW1655 and DW1670 form the outside. I even tried a DOS flasher and it says no drive responding.

I guess I will get another drive from OD tommorrow.

Are you sure you have a DRU-810A drive and not a 820A? The 820A is a BENQ DQ60 drive. Try changing the IDE cable and if it still doesn’t work then your drive is probably dead from a failed flash. I always flash my drives in safe mode.

Yep model is DRU-810A-R on the drive case. I have a DRU-820A, but it is in a external box and I use it with my laptop. BTW the DRU-820A is a Benq DW1670 not a DQ60.

Just tried a replacement drive and I used BQflasher this time and another machine. Same as earlier, flash finished up fine and then it killed the drive dead. What’s happening here? My drives are dated April 2006. Could they have changed to a different model or something? What kind of dates are you other guys finding on your DRU-810s?

Did you flash this replacement drive in [B]SAFE MODE?[/B] I’d suggest flashing in safe mode since it seems you’re getting failed flashing of the drives.

The only thing I can think of is a different eeprom, but I doubt it.

Can you post a picture of the label on drive?
Then it maybe will be easier for us to compare. :wink:

BTW, don’t think “safe mode” has anything to do with it.

Here it is:


I’ve never had any probs with flashing in safe mode. I made the suggestion because obviously he killed the drive by flashing it in windows. OP never once mentioned he if he flashed it in safe mode the first time around or with the replacement drive. :stuck_out_tongue:

As for the picture he posted it looks like the drive could be different. Look at the model number on the drive #DRU-810A-R. Which could be why the flashing of the drive failed. Just my 2 BIG CENTS! :wink:

I just installed a IO magic version of a DW1655 and had no problem crossflashing to a real DW1655 with the same setup as before. I have a hunch that Sony is using DW1650’s now. I think that -R at the end of the model number may be the key. I guess the only way to find out is to find someone with nerve to try a crossflash to a DW1650.

BTW I used XP and did not use it in safemode.

I was going to suggest to you to try crossflashing that drive with 1650 firmware. But it seems you may have returned it and got the I/O magic rebadged 1655 drive. :slight_smile:

I wish I could have, but I couldn’t flash the drive with DW1650 firmware as was very dead. It did not show up in the BIOS and would even open the tray. I used a dos flasher and it couldn’t find it.

now try to remove your IDE controller driver from windows and restart windows to allow windows to redetect the controller again, hoping it will find your drive. Once it finds your drive, reflash it back to sony firmware. The drive is too new to be a BenQ 1640 unless Sony has binding contract with BenQ to supply them BenQ 1640. Sony could be buying any model of BenQ OEM drive in bulk and rebadge them. So it could pretty well be a newer BenQ drive.

That wouldn’t have helped me. It did not show up in the BIOS at boot up. I used a dos flasher form dos and it couldn’t find it.

I have to agree on the point of the drive being to new to be a DW1640.

What is this ?

810A-[B]R[/B]

What “R” ?
My 810A has no “R” :confused:

That’s what we are trying to figure out!

Have you tried BenQCVT.exe??

Maybe R = Revisited :bigsmile:

Google search only shows 810A , without R :confused:

I flashed my 810-R drive in safe mode & killed it. Reported successful flash but then…Same symptoms, Unrecoverable with DOS utilities. I know of another who flashed in DOS mode with same result…dead drive.
So it is not a Safe mode/DOS Mode vs WIN XP flash problem.

The 810-R is “not” a BenQ 1640.

Is there anyway to verify what model BenQ this Sony 810-R is?
Extract the firmware?
Open the drive and check chipset?
Or at least to prevent others from same mistake…