Recovering a Sony DRU-710A

vbimport

#1

G’day all,

Today I received a Sony DRU-710A. I decided to crossflash it to a DRU-800A but I forgot to OmniPatch the firmware (I should have known better!!) so now I’ve ended up with a “blinking drive”.

My question is this: I have a Gigabyte GA-965P-DS3P Rev3.3 on my test rig, which has 4 burners and 4 hard drives. I have tried to boot into MS-DOS using a USB flash drive and recover the drive using MTKFLASH, but the program reports that the IDE Channel cannot be initialised. Has anyone experienced this problem before? My boot “disk” is only basic and has COMMAND.COM, IO.SYS and MSDOS.SYS.

Regards,
TerminalVeloCD


#2

If the firmwares are compatible, the drive is just flashing the led because of the unexpected eeprom checksum. In this case it should be still detected by the BIOS and XP as DRU-800A and it can be flashed from XP. No need to boot dos.


#3

DRU-800A is the wrong firmware. It will never work! :disagree:


#4

Really? I thought firmware from SOHW-1633S to SOHW-1693S were interchangeable?

Regards,
TerminalVeloCD


#5

Not detecting under Vista X64.

Regards,
TerminalVeloCD


#6

The 1633 can be upgraded to 1653 only, whereas 1673 to 1693.


#7

Liteon 1213-1653, Sony 710 are compatable.
1673/1693, Sony 720/800 are compatible.
These two drive groups are not compatible, even they use the same MT1828E/MT1816E chipset.


#8

Hello,
It seems my LITE ON LH-18A1H is dead after applying EEPROM_Utility.exe (for upgrading to LH-20A1H)

LED is blinking and it doesn´t read anything.

It still apears to BIOS.

How do I receover this if possible?

MTKFLSH doesn´t seem to work

I tried MTKFLASH 1 W HL05.BIN but nothing happens.

Should I use XSF? Where can I download it from? RPC1 is down.

Thanks a lot for your help.


#9

G’day all,

Found out that MTKFLASH doesn’t like the Gigabyte GA-965P-DS3. I successfully recovered my drive on a system with an ASUS A8S-X motherboard but found out, to my disappointment, that the OPU is worn and cannot read or write discs.

A big thanks to all those who replied.

Regards,
TerminalVeloCD


#10

yescool2002, have you tried flashing with Flashfix from http://digi.rpc1.org/flashfix.htm? Note FlashFix.exe and UPX.exe must be in same folder. MTKFLSH may have similar requirement, but I’m unfamiliar with MTKFLSH and have not used it.