Reading/writing speeds over 15x aren't smooth with 1640

vbimport

#1

Hi,

I’ve owned this BenQ DW1640 for a few days now, but have come across a problem that I haven’t been able to solve.

When burning a dvd or doing a transfer rate test, the curve is not smooth after ~15x. I originally thought this was an ide cable or an Anydvd problem. After fixing it by disabling anydvd, it has returned.

The problem has since returned, and after trying many different ide cables, I haven’t been able to fix it. I have ensured anydvd is switched off, udma mode 2 is on. The BenQ is master to a liteon 52327s cdrw

I’ve tried 2 rounded ata133 80wire cables (from ebuyer), an 80wire flat ide cable, a 40wire flat ide cable, and an MSI rounded ata133 80wire cable (was using on my hds) I got with my motherboard.

Tried different discs, and known discs that have burnt with good quality.
All produce the samish results:


#2

Can you do a burst rate test in Nero CD-DVD Speed and let us know the result. Under Tests just stick in a burned DVD and click burst rate.:slight_smile:


#3

There no good above 12x.


#4

File->Options. Transfer Rate. Graph test length: Move the slider all the way to the right (Accuracy).

Q.


#5

I think you are misunderstanding me, ANY disc that i do a transfer rate graph on or burn a disc at 16x (discs that burnt perfectly fine at 16x, in my nec 3500 and the one good disc that didnt have the poor writing above 15x) has the problem. It isn’t just related to that one disc that I burnt. Seems like there’s a problem with reading/writing above 15x

It was already all the way to the right on accuracy.

Here is a burst rate screenshot



#6

You not running anything that is taxing on the cpu, like a distributed computing application?

Try change IDE cable, diff IDE port, try without the lite-on connected, try as slave.
What chipset does your mainboard use? have you installed its’ IDE drivers? if so, uninstall and try Microsoft default IDE.

Your burst rate is acceptable, i used to get 23MB/sec on my old mainboard and it could read to 16x fine. I did have a cpu issue though where it couldn’t sustain a speed much higher than 12x.

Check that the screws you have used to secure the drive aren’t long ones and not too deep in. If they’re standard short screws, make sure they’re secure and the drive isn’t rattling.

good luck, i understand how annoying it is for you. after all the above i guess your best bet is to compare with another benq drive on the same ide plug…


#7

Right this is crazy. I’ve sorted the problem out yet again.

AnyDVD is a pain in the arse.

I had to do EXACTLY what I did last time to disable it, i.e. let it autostart with windows, then right click it and untick “enable anydvd”.

What I tried to do was turn it off altogether by unticking the autostart.

Also, the problem remained even after manually starting AnyDVD then just unticking “enable anydvd”, it was only solved when windows has booted with AUTOSTART on.

Oh well, the extra 80wire flat ide cable I bought off ebay will come in handy one day.




#8

Uninstalled AnyDVD and the problem is back again :frowning:

So i thought i’d try removing the ide drivers (ms default) from safe mode.

And now I can’t reinstall them whatsoever :rolleyes:

Windows tries to and then afterwards gives a message for each channel (primary and secondary) that it can’t install the driver or something. Check the device manager and each channel just shows up as IDE channel with a yellow exclamation mark. No amount of rebooting fixes that.

Did a transfer rate graph anyway and it showed jaggy lines above 14-15x again.

Installed nforce SW IDE drivers (got an nf3 ultra based board). Same thing :doh:


#9

Uninstall the nVidia drivers from Control Panel Add and remove Programs (nVidea) IDE drivers only, or try the newest NVidia drivers as some say they work OK. STD MS IDE drivers usually work better. Your burst rate is fine so there goes my idea.:slight_smile:


#10

I’ve run into bigger trouble now, uninstalled the nvidia drivers using the add/remove option.

Rebooted, and the same IDE channel stuff came back as shown in attachment.

So this time i removed them all in normal windows mode and and then was unable to boot into windows. I got a blue screen every time, not even safe mode worked.

Eventually i chose to boot on the last known good configuration, and that got me into windows just now. But I’m not sure i’ll be able to get back into windows if i reboot again.

Can anyone help reinstall these ide channels properly?



#11

Thy right clickiing on the the IDE ATA/ATAPI controllers and click Scan for hardware changes. Did you only click remove IDE drivers in the ADD and Remove?


#12

tried scanning for hardware changes, didnt do anything.

yeah i remoevd the nvidia drivers using their uninstall utility, from add/remove programs.

They removed fine, but it just went back to the IDE channels like in the attachment, before i even installed the nvidia ones.

Found this

  1. Driver is not intended for this platform

If you keep getting the following error message:

There is a problem installing this hardware.

    IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

2005-03-30 – Johannes B. wrote: The reason for this error is often that Daemon Tools or Alcohol 120% are installed. In this case the solution described below would not work. But when you uninstall these programs and then restart Windows, it will then install the device drivers without any further problems.

So i’ve just uninstalled alcohol now, gonna try rebooting, but who knows if i can get back into windows!


#13

Alright looks like I’ve killed 2 birds with one stone and fixed the lot.

Uninstalling alcohol 120% sorted out the problem of not being able to install the IDE channels.

I rebooted and it sorted itself out.

Now it seems the jaggy lines are also gone on transfer rate graphs (and most probably 16x burns too).

Whether it was down to needing a reinstall of ide drivers after a switch of NEC 3500 -> BenQ 1640, or needing to get rid of alcohol, who knows.

Think I’ll just leave it like this for now, since it’s all working.




#14

Glad to here it. Happy burning!:slight_smile: