Read error when using SATA drives as source?

I get the same read error 400 when I try to use any of my 3 SATA drives as source. (LG H62N, Samsung SH-S203B and a OPTIARIC 7170B connected to a SATA to IDE Converter).

My Lite-On LH 20A1P and my LG H55L have no problems as source with the same disc’s?

Any ideas folks? My SATA drives work as source and destination with all my other software…

TIA :slight_smile:

Hello! Anyone out there with some ideas? :slight_smile:

I’ll help you 4hams. What do i need to recreate this? I have 3 SATA ODD’s.

  1. Original store bought disk
  2. How far into encoding do you get this error 400?
    3.?
    4.?

Hey thanks Rolling56!

No matter what movie I try new or old, when I use one of my SATA drives as source the program gives me a read error 400 but does not show this in the log.

If I use my IDE drives as source I have know problems. I can also use the SATA drives as destination with no problems.

These are original store bought discs and the read error happens when scanning or within about 5 seconds of starting the read process.

Here are some screenshots of the error.



By the way all of the common settings are set at default.

Hi 4hams,

You problem is caused by dirty/scratched disc, please try to clean it or exchange a new one to see the result.

Best Regards,
Fengtao

Thanks you very much for the reply! :slight_smile:

I have to disagree with your answer regarding my error as the discs work great with the same drives in question when using other software.

Also when using my IDE drives with these discs and Fab it works fine??? Any other ideas? :slight_smile:

I have tried numerous dvd’s. Here is the latest which is a disc that I have copied about 4 times and is in prestine condition.

As stated if I use one of my IDE connected drives I have no problem copying and can set the SATA drives as source and everything works great?


4hams no problems here sorry.

I notice on your screen shots the times and percentages don’t jive.

Thanks rolling56! I have uninstalled and removed registry settings about 4 times now and cannot figure it myself?

And why does the program work fine if the source I use is one of my optical drives that are connected via an IDE chanell? :confused: :frowning:

That’s a good question :doh: i don’t know. I do believe that the discs are clean though and that’s not the problem.

Thanks again! :slight_smile:

Since the disc can be read from IDE drive, I think it’s not a DVDFab problem. DVDFab use normal Windows SPTI interface to read DVD, we don’t know if it’s IDE or SATA.

I’ll suggest two things:

  1. Update to latest firmware;
  2. Check if other CD/DVD software is installed, uninstall them to see the result.

Hi :slight_smile:
Not having used one I can’t be sure. But could this have something to do with it?
I suggest trying a PCI SATA controller card.
Just make sure it is ‘Silicon Image’ based & has a flashable bios.
I have the Samsung SH-S203B, LG GSA-H62N & NEC AD-7170S.
Have tried both the mobo SATA & a PCI card without any problems.
So I can’t get my setup to duplicate the problems you have.

Hi :slight_smile:
Just thought I’d post this.

The Sammie & NEC are connected to mobo.
The LG & Lite-On to the PCI card.

Hi :slight_smile:
Using DVDFab. Recognises all drives.

Using the 2 drives connected to mobo.

Using drives on PCI card.

Hi :slight_smile:
Thought I’d better show the complete process.

1st SATA drive on PCI card as source (LH-20A1S) > SATA drive on mobo as Target (SH-S203B). Used Nero option. Full disc.


2nd Then reversed, so SATA drive on mobo as source (SH-S203B) > SATA drive on PCI card as Target (LG GSA-H62N). VSO option used. Movie only.

In both cases some Ritek G05 media used & written @ 8x.
Both were a total success.

Thanks fengtao!
The firmware is upto date. The software I have installed for burning purposes are ImgBurn, 1Click DVD Copy Pro and CloneDVD2.

1Click and image burn use the same pattin couffin so no conflict there and clone has always been compatible with these softwares.

Before I formatted a week ago all of these softwares worked fine with all my optical drives.
I will wait for the next update and try that?

@Zeb, thanks for the help and pics. I have never seen anything like this one before and will wait for the next update to see if that helps.

Before I formatted a week ago all of these softwares worked fine with all my optical drives.

sata controller chipset and it’s driver is my best bet