Read error on benq DVD DC DQ60

vbimport

#1

Hi, I have a daul format/double layer Internal Hal-Val DVD RAM model HDVD168DL. On my computer it read as a BENQ DVD DC DQ60.

The problem I’m having is when I’m using DVDFabDyrcryptor 3.0.7.0, it keep erroring out. It won’t read the disc at all. This is the error message I receive, “error while reading disc”. I try different DVD Movies including home videos, but still getting the same error messages.

The previous version of DVDfabDecryptor version 3.0.2.5 works fine, I don’t know if any version after that work or not. But starting from version 3.0.4.0 I’ve been having that same error message popping up.

Could this be because I need to update my optical drive firmware? If so where can I get the updates and how would I flash my drive with the new firmware?

Jason


#2

It shouldn’t have anything to do with the firmware, although it is a good idea to keep your firmware updated. It sounds like it may be an issue with DVDFabDecrypter, in which case you may want to post your problem in the DVDFabDecrypter forum here. In the meantime for ripping discs, you could also try RipIt4Me.


#3

or anydvd+dvdshrink