Rdp connection keeps getting dropped

I’m having a problem at work with my company laptop (Pavilion dm4, W7 professional SP1, 64 bit, Intel i5, 4 gb ram). I use it to connect to a terminal server, 5 minutes after connecting - I get dropped. Happens every time I connect without fail. We’ve pinged the terminal server and it’s definitely a problem on my end specific to this machine. Laptop has all available updates installed, drivers are up to date, no viruses or malware. All programs installed are 64 bit compatible. There are no printers or scanners connected locally. Here’s what the event log is giving me when the connection gets dropped:

Log Name: Application
Source: Application Error
Date: 6/28/2011 1:14:35 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer:
Description:
Faulting application name: mstsc.exe, version: 6.1.7601.17514, time stamp: 0x4ce7ab44
Faulting module name: ntdll.dll, version: 6.1.7601.17514, time stamp: 0x4ce7c8f9
Exception code: 0xc0000374
Fault offset: 0x00000000000c40f2
Faulting process id: 0x15ec
Faulting application start time: 0x01cc35b573b52d04
Faulting application path: C:\Windows\system32\mstsc.exe
Faulting module path: C:\Windows\SYSTEM32
tdll.dll
Report Id: 185b82ac-a1aa-11e0-ad9f-c80aa9320bb1
Event Xml:
<Event xmlns=“http://schemas.microsoft.com/win/2004/08/events/event”>
<System>
<Provider Name=“Application Error” />
<EventID Qualifiers=“0”>1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime=“2011-06-28T17:14:35.000000000Z” />
<EventRecordID>8139</EventRecordID>
<Channel>Application</Channel>
<Computer>wtlh122.fox49.local</Computer>
<Security />
</System>
<EventData>
<Data>mstsc.exe</Data>
<Data>6.1.7601.17514</Data>
<Data>4ce7ab44</Data>
<Data>ntdll.dll</Data>
<Data>6.1.7601.17514</Data>
<Data>4ce7c8f9</Data>
<Data>c0000374</Data>
<Data>00000000000c40f2</Data>
<Data>15ec</Data>
<Data>01cc35b573b52d04</Data>
<Data>C:\Windows\system32\mstsc.exe</Data>
<Data>C:\Windows\SYSTEM32
tdll.dll</Data>
<Data>185b82ac-a1aa-11e0-ad9f-c80aa9320bb1</Data>
</EventData>
</Event>

I really need to get this fixed, my productivity at work is suffering. No one that has looked at it can figure out the problem. If anyone can help, you’d have my unending gratitude.

I don’t think you are connecting to a terminal server but rather using terminal services, which is something quite different. Take a look at your task manager to see what’s running with mstsc.exe

hi,

see if this is applicable: http://support.microsoft.com/kb/2290154

Michael

[QUOTE=Whappo;2594067]Take a look at your task manager to see what’s running with mstsc.exe[/QUOTE]

Remote desktop connection, pretty sure it’s 6.1

You don’t say how you are connecting, wired or wireless?. What do you get if you right click on the little connection icon? Check the status, look at the properties, etc.

What operating system is the server you are connecting to?

mciahel nailed it. Changing the compression on the client side did the trick. Thanks everybody,