Random PI Problems when I check the Quality of DVDs

Hi, my dvd-drive is LITE-ON DVDRW SHW-16H5S LV4D.
The dvd that I am burning is Verbatim:

Unique Disc Identifier : [DVD+R:MCC-004-000]

Disc & Book Type : [DVD+R] - [DVD-ROM]
Manufacturer Name : [Mitsubishi Chemical Corp.]
Manufacturer ID : [MCC]
Media Type ID : [004]
Product Revision : [Not Specified]
Blank Disc Capacity : [2,295,104 Sectors = 4.70 GB (4.38 GiB)]
Recording Speeds : [1x-2.4x , 4x , 6x-8x , 6x-16x]

[ DVD Identifier V5.0.0 - http://DVD.Identifier.CDfreaks.com ]

The problem is, I keep getting random quality scores with CD-DVD Speed, usually very low. The optical drive used to work fine in my old computer, but when i moved it to my new computer, it started to get discs with low quality scores non-stop. The thing is, the discs seem to work fine when I try them on my PS2.
Can anyone help and tell me if the problem lies within the DVDs or the DVD burner? I apologize if this question has been asked before, but I don’t know what to search for to find solutions to this particular problem.
Thanks in advance for any help.

The first pic below is one test, the second one is another test with the same disc.

The first scan is odd, the sudden acceleration…?

First, do not multitask while burning and close apps which could be interfering with the process (like apps which require lots of HD work).

There are other solutions too:
Try other media.
Make a test burn with Nero CD-DVD Speed’s Create Data Disc and scan the created data disc - it will show a write speed graph when scanned which may indicate trouble.
Try another IDE cable.
Try the drive at another place (at another cable, power connector, PC…)
Try another drive at its place.
Try another power supply.

You will not be able to RMA a drive with test firmware. But if it worked reliably with your old PC, you could reinstall it and downgrade it to LS0W or YS0Z there.

Ok, this computer does not have any other IDE cables for me to use, lol and I won’t have the time to try the drive in another computer until tomorrow or so. So far, I tried changing the power plugs connected to the drive, but it didn’t make a difference. For now, I have the screenshots for the test data disc.

What could you make out of these graphs?
Thanks.
Oh yeah, closing apps doesn’t make much of a difference.



Hi,

do a Transfer Rate Test (TRT) with that disc (benchmark tab). There shouldn’t be any slowdowns. Also check the disc for dust, scratches and similar contamination.
And consider using stock firmware.

Michael

Hi, how would I downgrade the firmware? Do I just run the old firmware and install like normal?

Anyways, I did the transfer rate test. Here is the result:


Hi,

this does not work, as Liteon’s official flasher will refuse to work on your actual configuration. See, if there is a patched firmware for your drive on http://codeguys.rpc1.org But be careful not to flash the wrong drive or the wrong firmware, as the hardware query is totally disabled with these patched firmwares.

Anyways, I did the transfer rate test. Here is the result:
looks okay. Those small slowdowns might be due to applications running in the background.

Michael

Alright, thanks. I successfully downgraded it to the stock firmware, but it still has the same problems. I’ll try the drive in my old computer tomorrow to see if has the same problems there. If there is improvement in my old computer, should I get a new power supply?

I tried the drive in my old computer and I get the proper readings from CD-DVD Speed. For some reason, it does work properly with my new computer. Does anyone know why? Does it have to do with the mobo/CPU/PSU?

Hi,

So your drive is okay.

Does anyone know why? Does it have to do with the mobo/CPU/PSU?
There seems to be something wrong with the new system. I would check and possibly replace the IDE cable at first. Especially those long rounded cables often reveal problems, so you should use a flat ribbon cable (80 wired) that is 18" (45 cm) long.
Also there might be driver issues. To sort that out, you should use the generic MS drivers instead of those provided by the mainboard or chipset manufacturer.

Michael

After switching the IDE cable from this computer with my old one, I am pretty sure the IDE cables are not the problem.
Where would I be able to get the MS drivers? I can’t seem to find any.