R48VS08 Nightmare

I just bought a 48125W (to upgrade from my 24102B) from overclockers.co.uk and downloaded the VS08 firmware.

Ran the windows firmware update proggy as usual. Now the drive doesn’t even get detected by the motherboard, let alone windows. Even the eject button doesn’t work. It’s definately getting power (the LED lights on power-up) and I tried swapping IDE channels with my Pioneer DVR104. Still no joy …

The retailer say they wont replace cos a firmware upgrade is classed as hardware modification and there’s no liteon customer service in the uk (well not for the IT arm of the company anyway).

Any ideas - help is much appreciated !!!

KiNeTiCa :confused:

I don’t see any problem :confused:

If you had read the stickies, then you knew that you had a bad flash, and that there’s nothing special about the behaviour of your drive.
Follow the bad-flash-recovery instructions in the mtkflash guide.

You da man - thanks bud - I only just came onto the forum this morning …

:wink:

I also suffered a bad flash and I read the sticky, but I didn’t see anything about what to do if the drive can no longer be seen by the bios. My 32123S’s light stays on green and it is not detected in the bios.

If my pc doesn’t recognize the drive how can I flash to it?

Thanks

You didn’t read the guide. :slight_smile:
It clearly says that this is normal and doesn’t matter for mtkflash.

=D…this bad flash reversal…I like it. Great idea…who made it anyway?

:smiley:

Originally posted by alexnoe
You didn’t read the guide. :slight_smile:
It clearly says that this is normal and doesn’t matter for mtkflash.

Thanks Alex. You are 100% right (I just read it again). Sorry, I read it when things were working well, but I didn’t go back to it when I could no longer get my floppy drive to go to Dos (the bootdisk stopped working). In fact, with my drive attached my pc wouldn’t boot at all.

  • I reinstalled my OS which brought my floppy drive back into operation.

  • I replaced my 32123S with a 40125S (works well too).

Now that my a: drive is back in action, I’ll try to recover my 32123S now. Thanks for the info.