Quicktime problem

vbimport

#1

I have got the dreaded ‘error 46’ when I try to run quicktime in Windows, (lack of “ActiveX control”)

Where does one get an activex control. I have tried Apple but they don’t appear to have one. Tucows doesn’t appear to have one. Tried Tesco;s but no luck there…

Can anyone help please.


#2

You can try all the suggested fixes but I recommend using Quicktime Alternative, just google it.


#3

[B]The solution:[/B] There is an old NT utility called SubInAcl.exe that can be used to reset permissions in Windows XP and also in Vista.
[B]
Step 1: [/B]

Vista’s User Account Control (UAC) must be disabled for these steps to work (Control Panel -> Turn User Account Control Off). You may enable UAC back on after these steps. And you should run this as admin.

[B]Step 2:

[/B]Download subinacl.msi from Microsoft and install it.

[B]Step 3:[/B]

Download a modified version of reset.cmd from here and save the file in ‘C:\Program Files\Windows Resource Kits\Tools’.
[B]for Vista 64-bit:[/B] to ‘C:\Program Files (X86)\Windows Resource Kits\Tools’

[B]Step 4:[/B]

Open Command Prompt (press the Windows Start button and type CMD) and type the following without quotes (hit Enter): ‘cd c:\program files\windows resource kits ools’ [B]for Vista 64-bit:[/B] ‘cd c:\program files (X86)\windows resource kits ools’

[B]Step 5:[/B]

Now type ‘reset.cmd’ and hit Enter (without quotes). You will see the Command Line Tool running for some seconds. The issue should have been fixed and Quicktime should run again.

:cool::cool:


#4

Thanks for the replies.

Tried ‘Alternative’ didn’t work…

Reset looks too complicated for me.

I shall solve my problem by getting rid of quicktime and use Safari without music…

thanx guys…


#5

@platinumsword ; I used the icacls & takeown for setting permissions in my Vista OS.
I tried the SubInAcl.exe but it didn’t work for me. In fact I’m glad I had a backup of my OS.
I wasn’t using this for the OP’s problem .
I was doing a whole OS permissions change.
I checked the reset.cmd script file in the download by changing the extension to .txt & it mostly involved Quicktime permissions so it might work fine.
For any that download SubInAcl it is a powerful program & I recommend a good backup with Acronis or Ghost of your OS first before using it.
Don’t depend on System Restore for this.


#6

The reset was only to address the quicktime issue.

One should always make a backup before making changes of this nature.

:cool::cool: