Qsuite and firmware update programs crashing

vbimport

#1

After I installed my 1640 I went to upgrade the firmware from BSHB to BSKB and the firmware updater crashed after giving the warning message. So I found the .cvt file and upgraded with WinDWFlash.

Then I install Qsuite 2.0 and try to launch it. Crashes right after warning message. Rebooted to safe mode and tried again. Same problem.

After some more playing I figured it out. There is a bug in the benq software when detecting the drives in the system. From my sig you see that I have the 1640 and the 1625. Well, if I go into device manager and temporarily disable either the 1625 or 1640, then qsuite boots up.

Just thought I would let everyone know in case someone came across this same problem. If you have the same problem, please let us know what benq drives you have as well.


#2

motherboard?


#3

Try to give the drive you want to use with Qsuite the lowest drive letter, say you got the 1625 as g: and the 1640 as h:. If you want qsuite to work with the 1640, switch them around. I can’t promise it’ll help, but it’s worth a try.

Q.


#4

Every time I start qsuite I receive an error message saying that it function only with benq drives. This is because I have my benq set as slave, whereas master is my liteon 1633. Maybe switching your drive as master can solve your problem.


#5

I received my 1640 yesterday BSHB. Flashed to BSKB and loaded QSuite 2.0 with no problems. But i don’t have 9 drives like you do :slight_smile:


#6

I have my 1620 as primary master and the 1640 as secondary master and get the warning about only working with BenQ drives but have no issues with fimware flashing. Qsuite sees both BenQ drives and offers utility for both.


#7

But you have two benq drive in the same channel; I have a liteon 1633 as master and a benq 1640 as slave.

Maybe kwkard have a similar config, i.e. two different drives on the same IDE channel, and benq is NOT set as master.

It’s only an hypothesis :slight_smile:


#8

Both my benq’s are set on the motherboard ide connectors. 1640 is PM, LG is PS. 1625 is SM and Nec3500 is SS. But the LG is the 1st drive letter in my system. And I get the same message as geno888. I click ok and then I select the 1640 from the drop down box and all is well. I will try playing with the drive letters after work.

Almost forgot, I have a Gigabyte GA-7N 200 Pro mobo.


#9

Actually I have this:

Primary Master: BenQ DW1620
Primary Slave: LiteOn SOHW-1693s

Secondary Master: BenQ DW1640
Secondary Slave: Matshita DVD-RAM SW-9585


#10

I have the 1640 and 1620 on the same IDE channel and mine Qsuite works fine. Sounds like the same problem we had with my brothers computer (Nforce 3), once we put Std MS drivers in it flashed fine. Is this (Gigabyte GA-7N 200 Pro mobo) a nVidea based Mobo?


#11

I have standard microsoft IDE drivers on an nForce 2 mainboard (asus A7N8X Deluxe). My only complain is that when I open qsuite the drive selected by default is my liteon, but when I choose benq all go without problems. My liteon is set as master, so I thought that maybe the problem was in master/slave settings.

I never tried to change drive letters. Anyone tried?


#12

Yes it is an nforce board. I am also using standard ms ide drivers.


#13

Hmmm. Well maybe I spoke too soon about Qsuite working OK. When I call it up it goes directly to the 1640 which is Primary Master for now, when I try to go to the 1620 I get this error(below).
@kwkard. Have you tried flashing in safe Mode?



#14

That error message is normal [I presume], if you keep clicking okay the tabs unique to the 1640 will disappear and only the ones relevant to the 1620 will remain.

I have my 1620 as master and the 1640 as slave on the same channel and if you switch back and forth that error message is what comes up, they could have done the UI switch a little more cleanly…


#15

Maybe qsuite2 is a little buggy?


#16

I tried it with qsuite 1 and the same thing happened.
@crossg: Yes I did try flashing in safe mode and the same thing happened. It has to be some bug with detecting drives I think.