QSI SBW242B firmware needed

vbimport

#1

My QSI DVD Combo Drive didn’t read most of the DVDs. (Yeah, I tested them on other DVD readers, and they work fine). So I tried to update the firmware. Found one UD30. Flashed it. Now it doesn’t see ANYTHING…

So,
I need a QSI SBW242B firmware.
I have searched the web for 24 hours. And I found out there are 3 firmwares.
UK54, UX81 and UK56(not sure about this though)

Does anyone know which one is the latest/best, and can anyone show me a way to get it?

With my best regards to whomever replies this. :bow:


#2

Hello,

I also have a QSI SBW242B drive in my alienware laptop.
It sucks, doesn’t read many types of DVD’s

Has there been any updates on the search for a successful firmware?

(would really appreciate an email - thanks)

Regards
Stu.


#3

Well - mine gives a clicking noise for almost all discs, DVDs never read, CD’s are okay for 30secs then click to hell. Writing things yields no burn, a light coloured burn with heaps jitter and errors C1 and C2 or a frozen drive. RMA? I think so!


#4

mine works fine!!!


#5

I rma’d mine for a replacement which now works, but squeals when reading … high pitched. :frowning:


#6

there is a firmware from Dell for some notebook that uses the same drive, that works against this clicking and aktivates DMA.
also there is a firmware you might try on this page under firmware->nu tech. I think its called ebw-242.
http://forum.rpc1.com/dl_firmware.php?download_id=1709
here you can get a working firmware but it will read DVDs only at 4x


#7

have you considered the possibility that the drives hardware might be broken?
the UD30 worked on my sbw-242.


#8

I can’t get any flash completed since I have UX51 f/w


#9

My drive also doesn’t read most DVD’s.

I also have looked for a firmware update without success. My current firmware version shows up as UX52.

Maybe these drives are just poor quality.

I’m able to read and write CD’s OK so maybe I should just leave it alone. I don’t really need to view DVD’s anyway.


#10

The New Firmware for LG GSA-4163B A105 is not worked.
DVD burns, funtion is not correct


#11

OK, UD30 did not work with DMA support but the older UD27 did!
The only website I have found everytime I searched was this:
http://forum.rpc1.org/dl_firmware.php?category=15&manufactor=33
there you can get all the available firmwares.
I have not tryed the Sony/VAIO ones.
The DELL UD27 works for me. I have a ACER Aspire 135xxx. the firmware originaly identified the drive and version as SBW-242B.
At that site the drive I got is called: QSI SBW-242U.
QSI is the same as NU-tech

now a few search terms: ebw sbw 242 udma


#12

Has anyone figured out a fix for this yet? UD30 borked my drive too, and UD27 refuses to flash. Someone has the same problem here and someone posted their original working firmware, but the links are now dead. Ideas, anyone…?