QSI SBW-241 Problem

vbimport

#1

Hello!

I’ve got a DVD/CDRW-Notebook-Combodrive, Model QSI SBW-241, and this drive doesn’t seem to read burned-DVD of almost any kind. I tested it with Taiyo Yuden G02, which it doesn’t even recognize, with Ritek G02, which produces read-errors, although readable on every other drive, including notebook-drives of other brands, and with Ritek G04, which kind of worked sometimes (I had to insert them like 5 times to get them recognized, then they work more badly than well).
From the posts here and in newsgroups I learned that many people have problems with this drive, but noone seemed to have a solution. Does anybody here know that problem and how to fix it? Did for example anybody flash a new firmware without destroying the drive? Any help appreciated.

Joe


#2

Welcome

Did you visit this page on your seach. :stuck_out_tongue:

BTW, with drive of that age, maybe your laser lens needs cleaning. Google.

:slight_smile:


#3

Hi!

Thanks for the welcome and your answer.
I read the site, but didn’t understand if I can flash every firmware or if the firmware is hardware-revision-dependent. My firmware on the drive is VX09, and it is even printed onto the drive. The page does offer a firmware for my drive, but as I understand it, it’s just to make it region-free. Later firmware-revisions are available, but do they fit onto my drive or do I destroy my drive trying to flash them on (there must be a reason for all those ‘old’ revisions still on the page??).
As for cleaning the lens, it looks perfectly clean to me and there are no problems reading or burning cds so far. The drive is just 1 year old, anyways. Nevertheless, if I don’t find a different solution or someone who actually flashed his drive with a different firmware and had success, I’ll give it a try… it’s always a risk to mess with the lens.

Joe


#4

Hi!

I want to give an update on my situation, just for the history/archive, so everybody with my problem knows what works and what doesn’t.

What I did:
1.) I flashed firmware VX11-1 and EY02, they both work but offer no improvement for my situation. I flashed back my old firmware afterwards.
2.) I then cleaned the lens with isopropyl-alcohol and a q-tip. After that the drive could read DVD-R and DVD-RW, except for the bulkpaq Taiyo Yuden, which I found out are fake. DVD+R/RW are not supported and don’t work. DVD-RW sometimes need to be reinserted to be detected.

So pinto2, thanks for your advice, that kind of worked for me. Nevertheless this drive is not ideal, for the bulkpaq-DVD-R work in every other notebook-drive I could test. My question still remains: does anybody know which drive fits in as a replacement for the QSI (by that I mean drives with button and LED on the same place and the same way of fixing the frontcover)?

Joe


#5

If the cd’s continue to burn with errors then you need to use a CD-r media of speed 1-16x. The QSI (Quanta Storage INC.) SBW-241 was designed using these low speed media but will still write at 24x on these CD-Rs. The reason why so many people are getting errors is because the QSI SBW-241 was not modified to work with high speed discs, that is why cd-rw discs work because they have a speed of 1-10x.

Try Ricoh 1-8x discs, they work perfectly on the QSI SBW-241 and can be written at 24x MAX too!!!


#6

Hi, I have your same problem with my qsi sbw-241. I reflashed it with the latest Compaq-Qsi Firmware but the problem remains. I tried to clean the len first… It doesn’t read burned dvd or sometimes it read the dvd partially.