Px-R820Ti SCSI Problems

I’ve just got my new (well old actually!) plextor 8/20 internal cd-r drive, along with an Adaptec 2904 PCI SCSI card and 50 pin cable. The SCSI card installed fine and was auto detected by WinXP Pro (SP1). I then shut down and attached the cable to the cd drive and the SCSI card.

Windows booted fine and the pc ran smoothly for about 5 seconds until it just froze with no warning messages. I restarted and detached the cd drive from the SCSI bus and everything was fine again. Whatever i do i can’t seem to get the drive to work - or to get Windows to run with the drive hooked up! :frowning:

I have no clue how SCSI buses work so i could be missing something very obvious, but any help given would be much appreciated! :iagree:

Thanks :slight_smile:

The card generally has a setup utility to set the ID. Either keep the card at the default of ID 7 or at least set it to a different ID than the drive, i.e., the drive at ID 4, the card at ID 7 or something other than 4. The drive should also be terminated. There should be a jumper on the TERM jumper pair on the drive. Plextor drives also have a Parity jumper…this should be installed also. Plextor has the manual posted on their site.

The 820 is an ancient drive. Is this “new” for you or a refurb from Plextor? The drive could be a classy boat anchor…

The SCSI card should also be terminated, check that both ends of the SCSI cable have devices that are TERMINATED via jumpers or resistor packs (small blue or black components with lots of metal legs).

I have a SCSI 12x Plex in my system so I can vouch for bob11879’s advice! Also, if you have a USB controller in your computer make sure it doesn’t share an IRQ with your SCSI card!! I had a nightmare where this was happening and due to my SCSI/USB controller sharing the same IRQ, USB resets were causing my drive to reset sometimes and fail while burning :frowning: So just check that too!

I don’t think there are any IRQ conflicts and the plug and play on WinXP installed and detected the card ok…i have changed the ID number from 4 to 2 so i will see if that helps.

I’m still not quite sure about this Termaination setup. I have checked the jumper is set on “Term” on the drive…is that enough or do the resistors have to be on the cable as well? And should there be a jumper on the host adapter also to terminate that end? :confused:

Thanks for the feedback!

Ok i’ve had some partial success at least…i can now connect the drive to the host adapter and boot into windows without it freezing. I think it was a simply a slight connection problem since resetting the components and cables concerned removed that problem.

My one remaining problem is that the cd-rw is not recognised at all by windows!!! :a Any insight into why this maybe so? The drive tray opens and closes and the LED is on so the drive has got power. The adapter card is also recognised so…maybe a faulty cable, or are there any other common reasons for the drive not being recognised?

Thanks for all the help :smiley: :bow:

If the card and drive are the only devices connected (no other scsi devices in this configuration) both the host adapter and drive should be terminated.

If the card has a utility program, you should be able to verify the TERM setting for the card and set the host ID to something other than 2, and scan the SCSI bus in order to ID devices. If the bus scan doesn’t see the drive, it is either a bad drive or bad cable.

Many thanks for the help! Might try buying a new cable, but otherwise i guess the drive is scrap.

Px-R820Ti SCSI :cool: can not write a rw disc only r disc

Any problem with your plex 8/20 ?

Try a look in the bios of your scsi card to verify the parameters of the card and the speed transfer/ID/termination.

Try to use a jumper to enable “parity” setting of the drive.

I have very big problems too :sad:

Plextor 8/20 internal cd-r drive TLA #0503
Adaptec 2904 PCI SCSI card
50 pin cable
Running Windows XP Professional servicepack1
Aspi 4.60

Plextor ID4, parity on, termination on.
Scsi card ID is unknown…how can I set it to 7??? (Plextools is given this information)
The card has no bios…
The IRQ is shared with Intel 82371AB/EB PCI to USB universel host-controller on number 10, but there are no conflicts. maybe I had to change this but I don’t no how…

In device-manager I can see the drive and the scsicontroller. There are no new drivers for this card, I have the latest.

When I burn an image with Alcohol 120%, I get a write error 030C07, recovery needed, on about 89 %.
I used different media and the first cd was totally scrambled, not readable in Windows, then I get one fully working cd (sd 3.20.22) and it worked…

The next cd’s all has write errors…

Please, help me, I’m desperate.

What about disable USB devices from bios to see what happens?

Is set by standard to ID 7 (highest priority), especially on cards with no BIOS/setup.
Check all LUN settings you can get.

IRQ 10 is not the best setting.

Exchange the SCSI cable, they can break easily.
Is a TERMINATOR physically attached at the end of the SCSI-string?

It makes no sense…

With Plextools the ID is finally set to ID:7.

The IRQ 10 is not shared anymore…only the scsi controller.
All is terminated…

Can you explain to me what the LUN settings are and what they should be???

LUN is logical unit number and is set by the device. A HDD is always LUN 0, a ODD is always LUN 0 because they are single units. A tape changer or ODD jukebox generally has different units, say the robotic arm and different trays, so the system and software see them as different segments of the SCSI ID…so a device is ID 3, LUN 0, for example, the robotics are ID3 LUN 1, tray 0 is ID 3 LUN 2, Tray 1 is ID3 LUN 3, etc…so the software knows what specific address to send to make the unit perform as necessary.

Unless you have some sort of changer, all you really need to worry about is device ID and termination

Thanks for your reply…what I found out is that the problem is Alcohol 120% version 1.92…Blindwrite writes correctly…

Oh, another software issue. Good to know then.

Yes, but why is Alcohol not burning correctly, that’s the question… ;o((((