PX-760A, orange LED blinking 2 times, I/O error

vbimport

#1

I bought the retail version PX-760A a month ago. It performed as I’ve expected, wrote DVDs with good quality, read damaged audio CDs better that my other burner or standalone player (Tascam/Teac). Until now.

A week ago my Plextor started to reject DVDs it had just written. At the same time I continued to successfully burn other DVDs with that drive and these discs read OK in my NEC ND-4551. At this moment the Plextor won’t recognize both written and blank DVDs, but continues to read CDs.

Plextools won’t allow me to do anything to the drive as if it was empty. (I expected to ‘reboot’ the drive in Plextools.)

I have not performed any modifications to the drive. I decided to flash the deprotected firmware only if I really needed it.

The error:
Orange led light blinking 2 times (Auto adjustment failed). Windows shows “The request could not be performed because of an I/O device error.” The only ‘solutions’ on the windows part are to work in PIO mode.

The causes of these errors appear conflicting, one tells of a problem inside the drive, other suggests noisy communication with the motherboard.

What gives?


#2

Please tell me what is wrong with my decsription of the problems, so I can improve in the future. I asked the same thing via Plextor Techical Support and still got no reply. The only field I didn’t fill out was the DD in purchase date.

Should I do the self test with a CD? (Even if my problem involves only DVDs.)


#3

Yes, I think that’s a good idea, as it’s more than just a problem with DVDs now. :slight_smile:


#4

I believe I solved my problem.

It turned out that the drive did not recognize just DVD+R or just MCC 004 which are the only discs I use. I found a DVD-R and a DVD+RW, which were read ok.

Today I finally powered down my computer, but after booting up again the Plextor continued to reject my DVDs. I updated the firmware from 1.04 to hacked 1.06, no luck. Then I got an idea. What if I erase the write strategy that’s been created there for MCC 004? This was it. Now my Plextor behaves as before. :wink:


#5

@J7N - OT: I love your avatar :wink:


#6

Nice to hear that you got your drive back on track.
BTW. Plextor urges users to delete/recreate Autostrategy entries after every firmware update.


#7

To Arachne :: Thanks. I like your cat too. :wink: BTW, I do not know the cat in my avatar. I found a hi-res picture of him on the web.

Yes I know that, but to my surprise the Autostrategy starts to work as soon as you insert a disc, not just during burning. And I dunno why my strategy entry for MCC 004 got corrupted (it was the only strategy I had), the only modifications I did was set some settings, like tray speed using Plextools XL. I did not write firmware before.


#8

That Plextor seems to have a mind of its own. It no longer recognizes some poor CDs and reads all other discs very slowly (8x CD, DVD ~ 2x) as if silent mode had been enabled and cannot be turned off. I tried to play with the speed settings in Plextools XL and now the tray started loading and ejecting with a loud hit (as regular drives do). However until now, after upgrading to 1.06 operation was very silent.


#9

If you only got it a month ago, the warranty should be intact. I’d request an RMA at this point if it’s too late to get an exchange/refund from the store that sold it to you.