PX 760 does not work properly anymore

Hi,

I have used a Plextor 760 burner for about 2 months (I bought it on March 10) and I burned about 100 DVDs since, mainly Tayo Yuden T03, with very good results (measured with Kprobe2 on my Lite-On 20A1H).

Suddenly to-day, the PX760 burned a DVD at 0,5X (16X asked for) 1,5 hour ! with very bad results : 12000 PIF with plenty of 5 Pifs bunches. I usualy get less than 500 PIF with no pif bunch over 2.
I first thought it was a bad DVD, but it was the same with several others. I then burned the same file with the LiteOn, and the result was normal (though a little less good then PX760) 16X burn with 537 Pifs, and no block with more than 3 pifs.

Should I send the PX760 directly back under warranty, or could it be something not too bad and what tests are suggested to find out what is wrong ?

:slight_smile: Gabier

Did you try reflashing the firmware? Or it reverted to slow mode. Hold the Eject button until the LED blinks 3 times. If that doesn’t work check you UDMA Mode.

No, I did not change anything.

Check your DMA, as suggested. Refer to the link in my sig for instructions, and see if that helps. :slight_smile:

It was on PIO only. I corrected it and restarted the computer. Then the transfer mode was “DMA if available” (OK) but the “current transfer mode” was still “PIO”. I started a burn to see if something would change, but no : the drive is still revolving at 0.5X, and the current tranfer mode stays “PIO”.
Note that the device 0 (the Lite-on) has ULTRA DMA Mode 2.

I tried also a Write transfer test on the PX with a blank media. Again the PX was going at 0.5X.

:doh:

It could be a data transfer problem, for I noted (I burn with IMGBurn) that the device buffer was very often almost empty (going from 100% to 5-10%), whereas the memory buffer remained stuck at 100%. I think I never noticed such a behaviour before. The memory buffer usually partly empties (going from 100% to 50-70%).

I am beginning to think there is really something wrong with that burner.

:slight_smile:

[Edit]I forgot to tell you that I tried to hold the eject button until it blinks 3 times. It did blink but this had no effect.

You need to use 80-wire (Ultra ATA 66/100/133) ribbon cable and both the Plextor and Lite-On must show “Ultra DMA Mode 4” for correct operation. If still problems with new cable, disconnect the Lite-On and use the Plextor as Single Master (check jumper settings).

Hi cressida,

I will check what this cable is. But why did both burners work perfectly before if the cable is not the good one ?

:slight_smile:

Hi gabier - If you don’t think it’s the cable, you can try uninstalling the secondary IDE channel in Device Manager (and have it re-detected/installed after a reboot). I’d be looking for another cable anyway though.

I am not sure to understand. I have no “secondary channel” in my device manager, in the "ATA/ATAPI device controllers. I have

  • a primary IDE channel, with the LiteOn as master (device 0) and the PX 760 as slave (device 1) (I suppose so, because in the “advanced tab” there are the DMA options)
  • an ultra ATA storage controller
  • a SATA AHCI controller
    I do not know what these controllers are for

:slight_smile:

Help !! I am quite confused :doh:

I tried to switch Master and Slave positions between the PX 760 and the Lite-On LO. The results are quite confusing. Maybe some of the configurations are not valid, I do not know. The scheme is IDE-X(opt)-Y(opt) with X being the burner in position closer to the IDE slot and Y the burner which is further. “opt” is their Master (MS) or Slave (SL) position.
IDE-PX (Master)-Empty : the PX is in UDMA 4
IDE-Empty-PX (MS) : idem
IDE-PX(MS)-LO(SL) : PX is in UDMA 4 but the LO is not installed (does not exist in the device manager nor in the windows explorer).
IDE-LO(SL)-PX(MS) : idem
IDE-LO(MS)-PX(SL) : The PX is in PIO and the LO is in UDMA 2
IDE-PX(SL)-LO(MS) : idem
The last configuration was the one before the problem appeared.

The good point is that the PX is OK. It works well when alone in master mode.
But the bad one is that I am unable to have a configuration with my 2 burners in UDMA. If the PX is the master, the LO is not installed, and if the LO is Master, the PX is in PIO.
I do not know if, before the problems, they were in UDMA 2 or 4, but certainly their DMA was on, because they could both burn at full speed.
So something happened. Do I have an IDE controller problem, a cable problem or any other ?
Should I force the LO to be installed when it is a Slave ? How ?

:smiley:

X is usually Slave and Y is usually master.
I guess you could try with a new (preferably 80 wire) PATA cable :slight_smile:

Thanks evilboy!
I will search for a cable and let you know the result.
BTW I never use both burners at the same time. Moreover, when I burn, I try that absolutly nothing else happens in the computer.

Hi :slight_smile: - if you have no “Secondary IDE Channel”, the same tip about uninstalling applies to the “Primary IDE Channel” (in other words, the one with your 2 burners attached to it).

If you have one of those motherboards with a JMicron IDE controller, check the relevant threads about the correct drivers to use here @CDFreaks.

Hi guys :bigsmile:

No more confusion, although some mystery remains

Before buying a new cable, I thought I could put back in the Dell Dimension the drives which were in it when I bought it, in order to know if the problem was the same.
It turns out that both of these devices (a Philips/Benq burner and a “no-name” DVD-ROM) had both their jumpers set to “Channel Select”. I googled a little to understand what that means, and discovered that in that case the cable is quite non usual, because the pin 28 connects only to one of the drives, which becomes the master. I kept this setting this setting, and both devices appeared to work and to be in UDMA 2. Thus the cable seems to be OK too, but non “standard”.

I put back my PX and LO burners in the Dell, with their jumpers also set to CS. And, surprise ! :rolleyes: it works. Both burners are installed and set to UDMA. The PX, which I put at the end of the cable, seems to be the master and works with UDMA 4. The Lite-On (slave) works with UDMA 2.

The mystery is : why did it work with master-slave settings and then did not work :confused:

But the main goal is to have everything work and it is indeed the case. Thanks to all of you who have helped me to track the way things work in this difficult area.
:slight_smile:

The Lite-On is a UDMA4 drive like the Plextor, so Dell’s doing it no service. Maybe it’s a BIOS thing or maybe you can fix by installing a new ribbon cable or by installing the correct IDE driver. Whichever, glad it’s working again :slight_smile:

Didn’t realise you had a Dell - I’ve heard about Dells liking CS. :iagree:

Glad it’s fixed :clap:

Hi Cressida,

I think I have the answer to your question : why not 2 devices in UDMA 4 ? I got it in the Dell forum. It seems quite plausible.

The IDE bus has a maximum rate of 133 Mb/s. UDMA 4 is 66,7 Mb/s. Knowing that the overhead for the management of the bus by the IDE controller is somewhere between 10% and 20%, it is not possible to have 2 UDMA 4 devices on the same IDE bus running at full speed. The master first initializes at maximum speed, and then the slave cannot but downgrade at the next lower setting (UDMA 2).

Simple ! :wink:

Wether I live with my best burner (the Plextor) in UDMA 4 and my best scanner (the Lite-On) in UDMA 2, or I have to install the drives each on a separate bus. As the Dell 9100 has only one IDE slot, it would be a PCI or a SATA slot (if there are one of these left, I have not looked).

Things seem clear now unless you don’t agree with the views above.

Gabier :slight_smile:

Hi gabier :slight_smile:

Sorry, but that sounds a lot like an over-imaginative Dell-fan trying to justify another Dell idiosyncrasy. Most IDE controllers can run two burners in UDMA4 perfectly, you just don’t want to use them simultaneously (well, you wouldn’t even want to do that if both were UDMA2).

So it will be impossible to use two Pioneer burners on that machine, as they won’t work properly in UDMA2. And what about two UDMA6 (yes, 133MB/s) hard drives :confused: ? Is the first gonna be in UDMA6 and the second in UDMA0? Or will they get an even split UDMA3… lol :wink: ?

If the Lite-On’s happy in UDMA2, then you’re alright as you have them now and we’re not going to worry about it any more. But remember, no burning and scanning at the same time :smiley:

OK, Cressida, you may be right. But the result is the same : then the IDE firmware or driver is the culprit, not being able to downgrade the second drive only if a conflict arises. It would be only able to distribute the bandwith at initialization.

But what can I do about this driver if there is no update at the Dell site ?

So, as you say, I will live with it, waiting for an IDE update, or probably another computer.

Thanks for advices :slight_smile:

Gabier

The max. bandwidth is only a theoretical value and, unless you’re using both drives at the same time, there’s no conflict present requiring a downgrade of the second unit. Ideally, they should be allowed to run in UDMA4 as separate devices.

Again, unless you’re experiencing any problems, there’s no need to worry about or update anything. Luckily Lite-On drives are pretty tolerant on IDE and your drive will probably work fine in UDMA2 mode (even if it was designed for UDMA4). It may be a close call to burn DVD’s at the advertised 20X speed, but that’s more of a sport than real world use anyway. UDMA2 is good enough for 16X burns.

Hope this helps :slight_smile: