PX-755SA can't burn CD's but will burn DVD

I have a PX-755SA that I’ve had trouble with before: wouldn’t get DMA so I put it on a Promise SATAII150 Tx2plus card and everything was hunky dory *For a while…

Now I can’t burn CDs. I can however burn DVDs. I have tried going back to firmware v1.04 from v1.05 but that hasn’t helped. And I could burn cds just fine for a while after I updated firmware up to 1.05. I’ve updated the VIA drivers for my board (Asus A8V-E Deluxe) dispite that the 755 isn’t hooked up to the board. And still no results.

Why would I only be able to burn dvds and not cds. Sounds like a driver issue to me but what driver? How can I tell what needs to be changed? is this related in any way to a previously unsolved problem with DAE (ACMFORMATCHOOSE error) Why is this drive being such a pain in the ass? I’ve been good to it. I think?

I really need some advice I’ve spent too much money on this thing already.
What would you do?

Perform a self test of the drive with a CD (as described in the FAQ). As there are different lasers for CD (IR) and DVD (red), the IR one may have failed.