PX-716SA 1.05 firmware bug

vbimport

#1

I have noticed an annoying firmware bug in the new 1.05 firmware for the PX-716A/SA/UF. I would guess that the problem only affects the 716SA, but who knows. I have a PX-716SA hooked up to a Dell Dimension XPS Gen 3–this system uses an OEM Intel 925X motherboard (ICH6R SATA controller with 4 onboard SATA ports). My drive is TLA #0304 and made in China in January 2005. The 1.04 firmware worked fine with the drive and has no issues with this system, provided that the system is running with the SATA controller in ATA mode using Microsoft IDE drivers. I would like to note that if my SATA controller is in AHCI mode, Windows XP requires an Intel driver (part of Intel Application Accelerator) to see the SATA controller. Using the PX-716SA (with either 1.04 or 1.05 firmware) with this driver in AHCI mode results in a Windows XP STOP 0x00008086 error when certain programs (Kprobe used for a Liteon drive hooked to the same system and Pxscan if set to Speed=12) access the drive. I never received this error with Plextools or Nero when running the drive in AHCI mode. Anyway, the solution to this problem is setting the SATA controller to ATA in the BIOS, and reinstalling Windows XP, which allows native Windows XP Microsoft drivers to control the SATA controller. Now that I got over the Windows XP STOP error issue, I just upgraded the firmware to 1.05 and found a new problem. If I put a Fuj 4X DVD+RW (RICOHJPNW11) disc that was burned by this Plextor drive in the drive, open the drive in Windows Explorer, and then let the drive sit idle until it spins down, something weird happens. If I then after the drive has been idle open a folder on the burned DVD+RW that has icons in it, the drive refuses to spin up–it sits there with a yellow light and makes an on/off clicking noise (just loud enough to hear the on/off clicking noise). After a while, explorer locks up, and the disc has to be ejected to unfreeze the locked up Windows XP. This problem is solved by downgrading the firmware back to 1.04–the problem never occurred with the 1.04 firmware. Anyone else having this problem with the 1.05 firmware?


#2

I have had this a lot with CD-RW media, but only with RWs that have been burnt in another drive:

When I went to wipe them or tack on another session, the 716a would fail miserably and render the disc unreadable - Putting the disc in the drive would just result in it trying to identify the RW in an endless loop with the amber light on; Eventually, the system would lock up as requests to the drive queued up and I’d have to eject it to unfreeze the system :frowning:

My only recourse so far has been to fully erase the discs in my crappy old LiteOn 832S; Once the Plextor had burned the CDRWs from clean they worked okay and I could add sessions and erase the discs as I wanted!

It would seem the 716 has some issues with RW media of all types…


#3

i think plextor just wants dvdr support and kill cdrw since it seems the px716 fails alot for cdr’s and if it’s not fixed perhaps we should get some money back as compisation (as creative did for audity cards that weren’t really 24bit)


#4

I’ve used a DVD+RW that was burnt previously by NEC2500 and no problems so far…


#5

it’s pathetic to loose a burn on a 3ghz with 2 gb of ram at cas 2… theres no real reason for it to fail since theirs enough power to get perfect burns beyond the 52x… under heavy stress.

for a company who says they make quality products they do over look important factors :iagree:


#6

I CANT IMAGING what sick company policy would choose that strategy. Plextor was/is the GOLD STANDARD for cd recording…why would they choose to kill cdr(w)? Whats so difficult in maintaing the good name in cd recording?


#7

they got sued for false avertising which is exactly what plextor is doing if they claim it does work and in"reality" it’s very strict condictions and its not stated…

for creative it was either a discount or full refund they settled for a discount to all owners of those brands


#8

when did that happen?


#9

it was passed recently

http://www.audiocardsettlement.com/form.asp

to lazy to explain and links are so much faster :slight_smile: (for me) :stuck_out_tongue:


#10

tlotz - I have the same system and and drive the 716SA and when trying to run Kprobe it crashes my computer on both 1.04 and 1.05 firmwares. I have not tried pxscan yet.


#11
 Pellinore:  the Kprobe problem is the result of the drive being run in AHCI mode with the Intel driver (iaStor.sys) controlling the SATA controller.   Running Kprobe with this setup causes a Windows XP STOP 0X00008086 error.  This Intel driver is part of Intel Application Accelerator.  I don't know if it is the AHCI mode, or the Intel driver causing the problem (or both), but I strongly suspect the Intel driver--the driver seems to think the 716SA is a hard drive.  To solve this problem, go into the BIOS setup, and switch the SATA mode from AHCI to ATA, and then *reinstall* Windows XP and all of your drivers and software.  In ATA mode, the SATA controller uses standard Microsoft drivers--which is probably why the drive works perfectly and doesn't crash when Kprobe or pxscan is run (to be used on a Liteon drive, but while the Plextor drive is hooked up).

#12

Tlotz, I have a similar problem with my PX-716SA w/ 1.05 firmware and my ASUS P5AD2-E Premium motherboard (Intel 925XE/ICH6R chipset). I have a BenQ DW1620 and LiteOn SOHW-1633S connected to the ICH6R IDE ports as master and slave respectively, a pair of Seagate SATA HDs connected to two of the ICH6R SATA ports in RAID 1 mirror configuration, and the PX-716SA connected to a third ICH6R SATA port. I am running Windows XP Media Center Edition 2005, with Plextools Professional XL 3.00 and Kprobe2 2.4.2 installed. The Intel Matrix Storage Technology S/W (new name for Intel Application Accelerator) 4.5 appear to recognize the PX-716SA as an optical drive, at least within the Matrix Storage Manager application.

When I launch Kprobe2, the app windows does not appear, though I can see the thread within the task manager processes list. I am not getting any STOP 0x00008086 blue screens, but Kprobe2 is completely unusable.

I haven’t tried experimenting with different H/W or S/W configurations, but here’s a link to download the latest available Intel Matrix Storage Technology S/W supporting ICH6R RAID:

http://downloadfinder.intel.com/scripts-df/filter_results.asp?strOSs=44&strTypes=DRV%2CUTL&ProductID=1809&OSFullName=Windows*+XP+Professional&submit=Go!

If I find out more about this issue I’ll post again.


#13

If anyone with a motherboard featuring the Intel ICH6R chipset southbridge (915 or 925 series northbridge) is interested in booting a SATA HD in BOTH the AHCI and ATA/IDE modes, and even the RAID mode with a single HD (“RAID ready” mode), I have found a way to do it, without the need to reinstall WinXP!

By preparing the system ahead of time with a registry key insertion along with copying the critical storage driver binaries to the proper location, prior to switching the SATA controller mode, WinXP can be coaxed to boot off a HD connected to an “unlearned” controller, without the “STOP 0x0000007B Inaccessible boot device” blue screen occuring. This error occurs only because WinXP cannot access the proper storage driver for the disk controller during initial OS boot, and this happens after switching the ICH6R SATA controller mode from AHCI to ATA/IDE or vice versa. ICH6R AHCI and RAID modes use the Intel RAID driver, whereas the ATA/IDE mode uses the Microsoft IDE “inbox” driver bundled with WinXP. WinXP normally only knows how to boot using whichever storage driver was configured during initial OS installation.

If folks are interested in this “cross-booting” ability I can post the details.


#14

scan80269: we’re using different motherboards with different BIOSs is perhaps one reason why you aren’t getting the STOP error. Also, I am using the Intel Matrix Storage Technology (Application Accelerator) version 4.7–the updated Intel driver may also make our similar problems appear different. I would like to add that sometimes it is possible to get Kprobe to work without the blue screen STOP error–but usually once the error starts to occur, it is quite consistent. Updating the system BIOS has not helped–although, the funny thing is that after the BIOS update, Kprobe worked temporarily and then the STOP error occurred later. Now Kprobe always produces the same STOP error, despite the BIOS upgrade. I have another copy of Windows XP (dual boot) that was installed using the SATA controller in ATA mode and that is how I know that ATA mode solves the problem. Do you have the 1.05 firmware bug I described? Take a burned DVD disc (I don’t know if it occurs with non-DVD rewritable discs), leave it in the 716SA with 1.05 firmware loaded after opening the drive in Explorer until after the drive spins down. Then, open a folder on the disc and see if you can access it–preferably a folder with icons.


#15

last to firmware versions broke compatibility with cd r media… and nero 6 (latest)
would be nice if there was a fix since it fails aat closing the media…


#16

can you explain that a bit?


#17

for dvds it is fine… but when it comes to cd media r, rw ( cdrw )

the burner has issues finishing the burner when it comes to actually closing the disc (100%)

the command to close it never gets sent to the burner in the lastest nero… which is strange since this is a generic call to the burner which every burning program uses (aside from the very first programs)


#18

i’ll post a pic when i have time


#19

could this just be the media? In my experience, 1.05 made plextor more friendly to cheap CDR media, something important 4 me and something that never was an issue with my previous nec 3500.

please do. Also post media code


#20

The problem I posted with firmware 1.05 and the read issue is specific to the RICOHJPNW11 media. I have now tested the drive with other media (Verbatim 4X DVD-RW, and Verbatim 16X DVD+R) and determined that this problem does not occur with the other media I’ve tested so far. This is a huge relief–it is a possibility that the problem could be fixed by full erasing and rewriting the problematic RICOHJPNW11 disc with the 1.05 firmware installed. If not, I could just use the Verbatim DVD-RW disc I have instead. What I will say is this: even with the 1.04 firmware, the drive seems to have more trouble reading this RICOHJPNW11 media–at startup, if the RICOHJPNW11 meda is in the 716SA, Windows XP takes much longer to boot. But the 1.04 firmware could always properly read the media–hopefully a full erase/rewrite of the disc with the 1.05 firmware installed will solve the problem. This disc was formatted initally with my LG drive, so that could be the problem. I will also try another RICOHJPNW11 disc(s) that was formatted by the Plextor drive–I will post my results in a few days. The funny thing is that the RICOHJPNW11 disc has lower PIE/PIF error rates than the Verbatim 4X DVD-RW disc, yet the drive now shows evidance that it can read the Verbatim 4X DVD-RW disc better.