PX-716AL DVD Reading Problems

vbimport

#1

Hello there I’m new and need help!

I’m having trouble with my DVD player. It’s a PX-716AL and seems to have been working fine since I got it about 3 months ago. However, lately it’s being doing weird stuff.

When playing DVD’s it will randomly stop playing. This lasts for about 3 or 4 seconds during which time the computer is frozen. Then it will start playing again, 9 times out of 10 it stutters to begin with, then goes back to normal. This seems to happen at random times.

Things I have tried without any success.

  • Tried lots of DVD’s, all the same result.

  • Tried playing DVD’s through MPC using the Combined Community Codec and also PowerDVD 7. There is no difference. Video files played through MPC sometimes have troubles such as sounds breaking up or the sound cutting out all together. This maybe connected to the DVD trouble but I can’t see how. To be sure I uninstalled the CCC but this did nothing either.

  • Installed a shiny new X-Fi Fatal1ty to replace my onboard sound, however this has not effected it either.

  • Tried changing my IDE interface in Windows to Ultra 4, 2, and PIO but this did nothing either.

  • Flashed the firmware up to version 1.02 but this has had no effect.

  • Checked the BIOS settings and made sure it was on AUTO and LBA

  • It is plugged in as the Secondary Master IDE with the right jumper settings on the drive. There is not any other IDE drives in my system.

One thing to note that maybe a factor is Starforce. I did have it on my machine about 2 months ago and had used the drive for Read/Write operations while it was installed. I uninstalled it successfully using the Starforce remover from Boycott Starforce but I wonder if it has maybe effected my drive? I have heard stories of Starforce breaking drives (not physically) maybe a factor?

Any help is much appericated. I want to watch T2 (THX editon) with my X-Fi and 5.1 setup!

Cheers for listening :slight_smile:


#2

Try using a different (new) IDE cable. Often these cables do weird things.

Do you have an other computer to try it in (maybe a friend)? If problems are the same there the drive is most probably deffective.


#3

I tried it in my flatmates machine. It worked but not perfectly. It was like it was running slowly, you know, constantly stuttering very slightly. Not the sound just the picture. Sort of like it wasen’t reading the disc quite fast enough. As another point, as I tried my flatmates Sony in my machine, my machine wouldn’t even boot into Windows! I did leave the Plextor drivers on so it might have been conficting with them I suppose…

I’m going to put in my old Pioneer next and see what it does with that.


#4

I would suggest trying the cables first though


#5

K, I’ve switched the cable and connected it to the Primary IDE port rather than the secondary. Was watching Star Wars for about an hour and didn’t see any trouble. However, it is a bit random this problem so it might just be messing with me. Shall post back once I’ve done some more testing.