PX-716A Problems reading burnt media!

vbimport

#1

Hi,

First post here. This forum looks roadwise :slight_smile:

Ok, to the chase, the subject says it all. I have problems reading DVD’s i burn with my PX-716A. I cant even read the plextools setup on the bundled DVD. I can burn DVD+R/RW-R/RW just fine and they play just fine on other DVD-players both computer and stationary as well as my Xbox. This all applies to UDMA 4. Got a 80 pin connector attached to it because i have a HDD working at UDMA 5 as secondary.

If I go to PIO I can read the DVDs (as well as the bundled software) that I have burnt but at a speed most of you know is not a very fast one.

Specs:
FW 1.03
Win XP Pro SP2
Asus A7V8X-X 1006
AMD 2400+ XP
1GB RAM
Latest drivers for IDE Bus controls

In conclution: I have trouble reading DVD’s in UDMA 4 but able to burn them. I can read them in PIO.

Would appreciate conrete suggestions by people who have experienced the same thing or can contribute with valid suggestions.

NOTE: No “update virus protection” or “reinstall windows” and similar suggestions, please.


#2

Try uninstalling your nVidia IDE drivers and install the standalone Microsoft driver (you won’t lose performance, I swear). On nForce 2 mainboards, these are mostly the cause for trouble with optical drives.


#3

Thanks for a quick answer!

Although its stated on Asus site that this mobo uses nForce technology, it doesn’t. I use the standard VIA Bus master control. I tried using the standard dual channel ide control (standalone Microsoft) as you suggested with no luck.

I noticed that atapi.sys was blocked by alcohol 120% however unblocking it by uninstalling alcohol did not solve my problem.


#4

UPDATE:

In the mobo Bios i selected CD-ROM on Secondary Master instead of AUTO-DETECT and then DMA 2. Now it can read DVD’s but at DMA 2 speed only. How fun is this? :frowning:

If anyone has any idea of how to get it to work with UDMA 4 please help me!

(NOTE: When AUTO-DETECT is selected in the bios it automatically sets DMA to 4 even though I change it manually to 2)


#5

Your drive will not benefit from DMA4 at all … DMA4 is also known as UDMA-100 and will be utilized by HDD’s only (with a few optical drive exceptions that indicate DMA4 operation but never reach the max. rated burst transfer rates of 100 MB/s anyway)

DMA2 (or UDMA-33 with a max. rated burst transfer rate of 33 MB/s) is way enough for any optical drive’s burst transfer rate so don’t worry … an optical drive operating in DMA mode 2 is perfectly normal.

By the way, the main object is to operate in DMA at all since DMA (Direct Memory Access) takes load from the CPU during drive access.


#6

True that UDMA2 (UDMA-33) will work fine at the moment. However I confused it with the old DMA 2 standard which is only 16.6 MB/s equal to PIO mode 4.

The interface in Plextools 2.19 says: PIO mode 0-4, MultiWord DMA Mode 0-2(whatever MultiWord is???), Ultra DMA Mode 0-4.

For the moment i declare this case solved then as I can read on UDMA-2 mode. On a newer mobo I wouldn’t settle as easily though.

Thanks for the help!


#7

JeanLuc

UDMA-4 is ata-66 not ata-100

ata-100 is UDMA-5

ata-133 is UDMA-6

with my plextor 716 using pri-master and UDMA-4 I get burst rate of 45 Mbyte/sec, and only 25 Mbytes/sec if use UDMA-2


#8

Yes, you are right on that one … I obviously did confuse the numbers. UDMA4 is indeed 66 MB/s. :o

But I wonder how you can measure the burst rate (which must be the IDE transfer rate peak out of your 716A’s 8 MB buffer to your operating system’s cache) so accurately without professional low-level measuring equipment since I have my doubts on synthetic benchmarking programs’ accuracy.

Anyway, at 45 MB/s, the burst rate can be maintained for a maximum of 0,17 seconds (assuming that the complete 8192 kB of the 716A’s drive cache are utilized which isn’t the case IIRC) so this increase in speed (compared to 25 MB/s) will hardly be noticeable (if noticeable at all).

What’s more important is the fact that the drive will reach its full continous speed (reading/writing) and acess time even in U-DMA2 … at 33 MB/s the interface is still fast enough to maintain these speeds.

And I still keep asking myself if a VIA chipset (the Asus A7Nx series do feature nForce chipsets, not the A7Vx - my fault again) is the perfect partner for a high-speed optical device … I have seen way too many unexplainable problems with VIA/nVidia/ALi chipsets (and drivers) in the past.


#9

I just use a dvd disk with data and speed3.61 it has burst rate test i think you hit f9 as I recall.

As to VIA chipset I dont know this system is true intel 845 chipset with windows xp default IDE drivers.


#10

Probably is my old VIA KT400 mobo which is too outdated… Still, my Primary Master, slave as well as Secondary slave all run perfectly on UDMA-5 (all HDDs)

I’ve updated, searched the net, trialed and errored and still cant find any solution or anyone else with the same problem… I guess I’ll have to take it easy until my next mobo or Plextor comes out with some info about this…


#11

My next pc will be athlon64 cpu but I got make this one last for another year at least. I run all my opticals off the motherboard ata100 ports and HDD;s off my promise utra 133 card