PX 716 firware upgrade erro

vbimport

#1

I just bought a PX716A drive and it came with firmware version 1.3. I wanted to upgrade to version 1.4 so downloaded everything necessary but when i try to flash the rom i get an error 40 06 F6. What does it mean??


#2

try redownloading the FW updater, could be corrupted. i’d flash right after a clean reboot too.


#3

thanks for replying but i’ve downloaded it twice and i’ve also tried the embedde version (.exe which cointeins the firmware and updater together) and separeted version.


#4

im sorry that didn’t work. how do you have the drive setup? is it a master with no other IDE devices on the channel? if it’s not, try reconfiguring it as the Master drive. im sorry i can’t be of more assistance, i haven’t experienced that problem yet. i hope your drive’s ROM chip isn’t bad…


#5

It’s master and i have a philips DVD reader as slave on the same channel


#6

hmm, can you flash to other versions of the FW besides 1.04? try downgrading to 1.02. if that fails, most likely it’s the drive’s ROM (unfortunately).


#7

Does your new 716a work normally? I bought one and got the same error when updating the firmware and it couldn’t read CDs/DVDs well. I found out that in my BIOS the IDE speed was set to UDMA-4. Lowering this to UDMA-2 solved the problem. My computer uses an 40 wired IDE-cable and those do not support UDMA-4 transfers. With an 80 wired IDE cable I then could go back to UDMA-4 without any problems.


#8

thanks everybody, i discovered that i need to turn DMA off before trying to upgrade. Now i have version 1.4, but i have a lot of problems with video DVD