PX-716 + AMD controller problem solved

vbimport

#1

if you use your plextor drive connected to an AMD IDE controller you have to short the DMA jumper
i solved DVD read/write problems on my 760MPX chipset’s IDE controller
the firmware update does not cause a hardware failure anymore


#2

Changing the jumper puts it into PIO mode and slows down the write. Check with Plextor tech support. I hear they have a 716A firmware to correct for the AMD issue. Could be wrong, but check with USA tech support.


#3

thats not right
plextor faq says:
the jumper sets MultiWord DMA mode 2 instead of UDMA mode 2
i can burn dvd with fullspeed without buffer loss


#4

without the jumper i was not able to upgrade the firmware
the drive gave me an hardware error code (firmware transfer failed)


#5

Are you sure about that? MDMA2 gives a max (theoretical) transfer rate of 16.7 MB/s (see e.g. here), 16x DVD burning requires 22 MB/s
Try a 16x simulation (full DVD)…

Regards, :slight_smile:

ET


#6

There are a FEW treads in this Forum that did talk about the inability to update to new firmware unless it was flashed with the multi-word jumper in place. After flashing the jumper was taken off to go back to UDMA-4. I don’t remember the reason why !!!


#7

Generally it was due to timing issues with the IDE controller. Data would get corrupted or messed up and the drive would not flash. Setting the DMA jumper sets it down to MWDMA or PIO4…both 16MB/sec. Not 33 or the UDMA66 the drive needs to run at for full transfer. Check with tech support for the firmware upgrade for the AMD chipset and you can pull the jumper.