PX-712A Ripping at 2x no matter what I set in Prefs

vbimport

#1

I am using the PlexProfessionals Tool (or whatever it’s called) and I changed the DVD-rip speeds to it’s unlocked mode, as suggested in the FAQs.
But now when I rip one of my DVD’s, it still takes the same amount of time (about an hour for a movie), which suggests to me that it hasn’t increased it’s speed. I saved the preferences, but still the same thing. Any ideas?


#2

First, make sure your PX-712A is operating properly in UDMA mode 2 witrh your computer. Full read speed cannot be achieved if the PX-712A is only in PIO mode.

Have you tried ripping several different movie discs? Some discs may have very marginal quality and may cause the drive to reduce speed in order to read correctly.

You can use the “Read Transfer Rate Test” feature of PlexTools Professional to determine the read speed for your DVD discs. Note that the PX-712A has a top read speed of 6-16X (CAV) for single-layer stamped discs, and 5-12X (CAV) for dual-layer ones.


#3

Hi Spartan

You have to enable SpeedRead DVD every time you reboot your computer: Insert your DVD, Run Plextools, Go to Drive Settings/Advanced Tab and tick SpeedRead DVD.

Alternatively when the drive is empty hold the eject button for 3 seconds until the LED flashes green 3 times and let go. The drive will open and SpeedRead DVD will be enabled for the DVD you insert until you eject the disc or reboot your computer.

Hope this helps,
Taroth